Opened 6 years ago

Closed 5 years ago

#444 closed Bug / Defect (duplicate)

openvpnsrv.exe not detecting death of openvpn.exe

Reported by: jhaar Owned by:
Priority: major Milestone:
Component: Generic / unclassified Version: OpenVPN 2.3.4 (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

Hi there

We had an incident over the weekend where a user reported openvpn (Win7/64bit running as a service) suddenly stopped working. They checked TaskManager? and saw openvpnsrv.exe was running, but openvpn.exe was not. The service was still marked as active

So they did a stop/start on the service and then it all came right. We have configured the "openvpn service" to autorestart after 1 minute when there's an outage, but I suspect that tracks the state of openvpnsrv.exe - not openvpn.exe? The openvpn logfile contained no explanation of what triggered his error, but EventLogs? contained a record of the event (attached)

So I tried duplicating this issue myself. If I kill openvpn.exe using taskkill (obviously when also running openvpn as a service), the same thing happens - it isn't auto-restarted.

Surely openvpnsrv.exe should be doing that? My expectation of a service is that it's always "running".

Thanks!

Attachments (1)

eventlog.txt (741 bytes) - added by jhaar 6 years ago.

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by jhaar

Attachment: eventlog.txt added

comment:1 Changed 5 years ago by Samuli Seppänen

I don't think openvpnserv.exe does any tracking of the openvpn.exe instances it creates. It probably should, as you say. In the case it fails to autostart a particular OpenVPN instance it should also notify the admin somehow, e.g. send a system event to Windows.

comment:2 Changed 5 years ago by atze

This seems to be a duplicate of #110, and in my installation this behaviour leads to openvpn tunnels not surviving hibernation (which did perfectly fine in 2.1.x), like in #71.

comment:3 Changed 5 years ago by Samuli Seppänen

Resolution: duplicate
Status: newclosed

#71 has been reported on 2.1.4, too, so I doubt much has changed in openvpnserv.exe since then.

Closing this as a duplicate of #110

Note: See TracTickets for help on using tickets.