Opened 10 years ago

Closed 5 years ago

#110 closed Bug / Defect (wontfix)

openvpnserv.exe does not exit even if there are no openvpn.exe processes

Reported by: Samuli Seppänen Owned by: Samuli Seppänen
Priority: major Milestone: alpha 2.4
Component: Generic / unclassified Version: OpenVPN git master branch (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords: windows openvpnserv nssm
Cc:

Description

Currently openvpnserv.exe does not exit if openvpn.exe exits, e.g. due to a bug in a down script. As discussed in this thread and in the IRC meeting on 24th Mar 2011 this behavior is undesirable: openvpnserv.exe could safely exit when no openvpn.exe processes are running. This way people could leverage on Windows service auto-restart-after-crash capability.

Change History (11)

comment:1 Changed 10 years ago by Samuli Seppänen

Priority: minormajor
Version: 2.2-beta / 2.2-RC2.3-beta / 2.3-RC

comment:2 Changed 8 years ago by Samuli Seppänen

Keywords: windows openvpnserv added
Milestone: beta 2.3release 2.4
Version: 2.3-beta / 2.3-RC2.3.1

Nobody has touched openvpnserv.exe code in ages so this issue still persists...

comment:3 Changed 7 years ago by Samuli Seppänen

Version: 2.3.1git master branch

comment:4 Changed 6 years ago by Samuli Seppänen

#444 is a duplicate of this ticket.

comment:5 Changed 6 years ago by Gert Döring

Shall we just ship a (2.3!) installer with the new service management thingie, and close all bugs related to openvpnserv.exe?

comment:6 Changed 6 years ago by Samuli Seppänen

cron2: that is an option if nssm proves to be robust enough. I'd keep it alongside openvpnserv.exe at least for some 2.3.x point releases before entirely scrapping openvpnserv.exe.

comment:7 Changed 6 years ago by Gert Döring

Milestone: release 2.4alpha 2.4
Owner: set to Samuli Seppänen
Status: newassigned

Yet another NSSM one :-) - and most definitely 2.4_ALPHA "really, really quick!"

comment:8 Changed 6 years ago by Samuli Seppänen

Keywords: nssm added

comment:9 Changed 5 years ago by Samuli Seppänen

Nssm is gone, but we have a replacement (openvpnserv2) for openvpnserv now. Can someone test if this installer fixes this problem?

Details in ticket 71.

comment:10 Changed 5 years ago by Samuli Seppänen

The old openvpnserv.exe could not restart crashed connections, so having openvpnserv.exe itself die, and letting Windows bring it back up would have made some sense. I say "some", because with more than one connection all would have to crash for this restarting to take place.

In any case, openvpnserv2 fixes this, as it will restart individual crashed OpenVPN connections. Closing this ticket as fixed. Please reopen if this is not the case in practice.

comment:11 Changed 5 years ago by Samuli Seppänen

Resolution: wontfix
Status: assignedclosed
Note: See TracTickets for help on using tickets.