Opened 5 years ago

Last modified 2 months ago

#1238 reopened Bug / Defect

trac can fail to email the reporter

Reported by: tct Owned by: Samuli Seppänen
Priority: trivial Milestone:
Component: Community services Version:
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc: Ecrist


These trac tickets did not email to me on replies:

Please add a simple reply to this ticket for my test.
Don't modify cc etc.

Change History (16)

comment:1 Changed 5 years ago by Samuli Seppänen


comment:2 Changed 5 years ago by tct

Test failed.

I received the initial post notification:

Full message header available on request.

But no notification of replies.

Checked gmail spam folder: no spam.
Checked gmail other folders: no notification.

I will receive notification of my own reply.

comment:3 Changed 5 years ago by tct

Notification of my reply received.

Note: Not threaded.

comment:4 Changed 5 years ago by tct

Oddly enough, my reply to my reply was indeed threaded correctly.

comment:5 Changed 5 years ago by Gert Döring


comment:6 in reply to:  5 Changed 5 years ago by tct

Replying to Gert Döring:


received !

Did you find a notification email moo for my comment on your ticket ?

Last edited 5 years ago by tct (previous) (diff)

comment:7 Changed 5 years ago by tct

Priority: majortrivial
Resolution: notabug
Status: newclosed

Sometimes things go wrong ..

comment:8 Changed 5 years ago by tct

So that people understand what is going on here:

If you fill out a ticket like #1229, where the reporter has only used the description field to describe the issue, then the reporter will not receive any reply email notifications.

If the reporter fills out a ticket like this one #1238 and adds a subsequent comment then the reporter will receive email notifications.

So, by default the reporter is not subscribed to the ticket unless/until they add a comment.

This does not seem to be conducive to how trac ought to work.

comment:9 Changed 4 years ago by tct

Resolution: notabug
Status: closedreopened

comment:10 Changed 4 years ago by Samuli Seppänen

I'll check if there is a setting to fix this.

comment:11 Changed 4 years ago by tct

Cc: Ecrist added

comment:12 Changed 4 years ago by Eric Crist

This might be related to the IPv6 PTR records and Gmail blocking those messages, @mattock.

comment:13 Changed 4 years ago by Gert Döring

Don't send mail to gmail over IPv6. This is a world of needless extra hurdles.

comment:14 Changed 4 years ago by tct

I received this message after creating ticket #1351

Warning: The ticket has been created, but an error occurred while sending notifications: (454, 'Throttling failure: Maximum SigV2 SMTP sending rate exceeded.') 

comment:15 Changed 3 years ago by tct

Yet another test post

comment:16 Changed 2 months ago by hummingbunch

Last edited 2 months ago by tct (previous) (diff)
Note: See TracTickets for help on using tickets.