Opened 3 years ago

Closed 3 years ago

#998 closed Bug / Defect (duplicate)

iOS connection to Watchguard Firebox: DNS settings still not aplied

Reported by: nicolasdw Owned by:
Priority: critical Milestone:
Component: OpenVPN Connect Version: OpenVPN Connect for iOS v1.2.6
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords: Watchguard vpn dns ios
Cc:

Description

Hi,

We use OpenVPN as an SSLVPN client on our PC's and iPhones to connect to one our Watchguard Fireboxes.

Since 1.2.5 we experience the issue that DNS settings are not applied. When we are in our internal WiFi?, connection to the LAN works as the DNS of the Wifi network recognizes these hosts. On 4G, this is not the case.

I removed 1.2.5 and installed 1.2.6 and downloaded the .ovpn files again from our firewall. The issue remains.

I read the work-around in the other bug report to switch the domain and DNS server settings. Problem is, these settings do not exist in my ovpn file, so I guess they're pushed by my firewall...

My ovpn file looks like this:

dev tun
client
proto tcp
<ca>
CERTIFICATE
</ca>
<cert>
CERTIFICATE
</cert>
<key>
PRIVATE KEY
</key>
remote-cert-eku "TLS Web Server Authentication"
remote host1.dyndns.org 443
remote host2.dyndns.org 443
persist-key
persist-tun
verb 3
mute 20
keepalive 10 60
cipher AES-256-CBC
auth SHA1
float
reneg-sec 3600
nobind
mute-replay-warnings
auth-user-pass
;remember_connection 1
;auto_reconnect 1

Please help!

best regards,

Nicolas

Change History (2)

comment:1 Changed 3 years ago by nicolasdw

Just to be clear: OpenVPN works fine on our PC's. The issue is on our iPhones.

comment:2 Changed 3 years ago by Antonio

Resolution: duplicate
Status: newclosed

Yeah, they are pushed by your firewall. However the bug is the same, therefore it does not require another ticket.

I am closing this ticket as duplicate of #982.

Since these settings are pushed by the server, you could still try to add the DNS setting in your config as:

dhcp-option DNS {DNS-IP-OVER-VPN}

and see if that helps.

For further comments please refer to the other ticket.

Thanks!

Note: See TracTickets for help on using tickets.