Opened 2 years ago

Closed 2 years ago

#996 closed Bug / Defect (fixed)

iOS: connection terminates upon opening of the app

Reported by: yankee77 Owned by: Antonio
Priority: major Milestone:
Component: OpenVPN Connect Version: OpenVPN Connect for iOS v1.2.6
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

I am using both an autologin profile with inline certs and keys and also a config with external cert. In both types, the connection is established fine, but if I open the app, the connection immediately terminates.

Change History (6)

comment:1 Changed 2 years ago by Antonio

Component: Generic / unclassifiedOpenVPN Connect
Owner: set to Antonio
Status: newassigned
Summary: iOS - connection terminates upon opening of the appiOS: connection terminates upon opening of the app

Does it mean that after connecting, you push the home button, then you click on the OpenVPN icon to open the app and it disconnects?

Does it happen all the time?

Can you please paste the log here after the disconnection?

Thanks

comment:2 Changed 2 years ago by Ozwel

It happens to me sometimes too.
Can you please add some logs, or at least the protocol and port you are using?

It happened to me when using TCP port 443, I have changed these settings to UDP port XXXX (random port) and now I'm all fine.

comment:3 Changed 2 years ago by Antonio

I think this was either the app killing the tunnel when swiping it away from the background tasks or some other issue that looked like the connection was getting killed upon opening the app.

In any case I'd wait for the new release and retest whatever the problem was.

comment:4 Changed 2 years ago by Antonio

v1.2.7 is being rolled out to the various AppStore? as we speak. Please test it once you have a chance to upgrade and update this ticket accordingly, if possible. Thanks!

comment:5 Changed 2 years ago by yankee77

Yes this was the termination upon swiping it away from background tasks and I can confirm a fix with 1.2.7. Thanks guys! Now if Apple can just get on that pkcs12 issue...

comment:6 in reply to:  5 Changed 2 years ago by Antonio

Resolution: fixed
Status: assignedclosed

Replying to yankee77:

Yes this was the termination upon swiping it away from background tasks and I can confirm a fix with 1.2.7. Thanks guys!

Thanks for the update! I am closing this ticket.

Now if Apple can just get on that pkcs12 issue...

If you are referring to using p12 bundles into .mobileconfig files, the latest update is in #985

Note: See TracTickets for help on using tickets.