Opened 6 years ago

Closed 6 years ago

#493 closed Bug / Defect (fixed)

Win2008 hangs after serveral OVPN start/stop cycles with TAP interface

Reported by: Sash Owned by:
Priority: major Milestone:
Component: tap-windows Version: OpenVPN 2.3.4 (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

after 3 Month of no replay its time to open a ticket :-(

i have a Windows Server 2008 (not R2) (which is Vista based you know) on a customer site, with installed ovpn 2.3.4 (x64; also tested 2.2.2 x86, with and wihtout ovpn gui).
All Win updates are installed. ovpn has a workng config. i use a TAP bridged network.

the problem:
the server is fresh rebooted. when i start the opvn gui i am able to start the ovpn instance and it will connect. when i stop the instance it will maybe stopped and now the problems begin. the instance cant get stoped after a few start/stop cycles. the gui cant connect to the ovpn instance and gets a zombi which cant be killed (not with the taskmanager nor with the windows service scheduler). the whole Windows cant be rebooted via soft reboot. it just hangs (most progrms wont work any longer/cant be even started). the only way to bring it to operational state again is to powercyle the system.
next was the try another build, so i used ovpn 2.2.2 x86 with the same result. next was not to use the GUI und use the system service manager, but after a few start/stop cycles the same problem occurs.

i searched the net and saw that there were smilar problems on windows with older versions of ovpn...there where fixes in source but never saw a comment that the problems were really solved.

so guys i hope for your help or even some hints to nail the problem down :!:

Change History (2)

comment:1 Changed 6 years ago by Steffan Karger

This sounds much like this issue with the NDIS6 tap-windows driver:
https://community.openvpn.net/openvpn/ticket/432

This is fixed in a newer version of the TAP driver, could you please try upgrading to 2.3.6, and make sure you install the new TAP driver?

comment:2 Changed 6 years ago by Samuli Seppänen

Resolution: fixed
Status: newclosed

No activity in 5 months and as syzzer says, there's a high likelyhood that this got fixed (in 2.3.5). Closing as "fixed". Please reopen if this bug persists.

Note: See TracTickets for help on using tickets.