Opened 6 years ago

Closed 4 years ago

#492 closed Bug / Defect (invalid)

Param ping-restart needs dev

Reported by: LinuxN00b Owned by:
Priority: minor Milestone:
Component: Generic / unclassified Version: OpenVPN 2.3.2 (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

With some tricks I managed to run Openvpn in a LXC container ( as a client ). The VPN connetion is working fine when I don't set any parameters. But now I want to use the ping-restart parameter.

When I only set this parameter I get this error message:

Options error: You must define TUN/TAP device (--dev)

So I tried to add a second parameter: --dev tun
Here I tried several devices but I had no luck. Probably because of the virtual environment.

But I really don't understand why the parameter ping-restart needs a device. It should be valid for every connection which can be established. So I am a bit confused. Maybe you can fix it? I am using Debian.

Change History (4)

comment:1 Changed 6 years ago by Gert Döring

please share your config (keys removed, of course) and log file. I'm wondering how it can work in the first place without a --dev statement...

Also, you might want to use 2.3.6 - 2.3.2 is getting old.

comment:2 Changed 6 years ago by Gert Döring

ping? I'd like to either reproduce and fix, or close as invalid, but I need a log file for that... (with "--verb 3", please)

comment:3 Changed 6 years ago by Samuli Seppänen

LinuxN00b: please provide the log files or we'll have to close this ticket.

comment:4 Changed 4 years ago by Gert Döring

Resolution: invalid
Status: newclosed

closing

Note: See TracTickets for help on using tickets.