Opened 3 years ago

Closed 3 years ago

#432 closed Bug / Defect (fixed)

OpenVPN.exe hangs upon reconnecting

Reported by: shio Owned by:
Priority: major Milestone: release 2.3.4
Component: tap-windows Version: OpenVPN 2.3.4 (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords: ndis6, windows, server
Cc: samuli

Description

After upgrading from I002 (old NDIS) to I603 (new NDIS) on Windows 7 SP1 x64, the main exe, running as a server, stops working if I use the "Reconnect" button on the GUI.
The exe doesn't answer and the process cannot even be taskill'ed.
Resource usage stays slow but the server isn't answering anymore so a restart of the OS is required.

It occurs only if someone is already connected to the server and it doesn't matter if the client is using the old or the new NDIS driver.
Reverting to the old NDIS driver also fixes the issue.

Attachments (2)

verb4.log (36.6 KB) - added by shio 3 years ago.
Server log (verb 4)
server.ovpn (343 bytes) - added by shio 3 years ago.
Server conf file

Download all attachments as: .zip

Change History (13)

Changed 3 years ago by shio

Server log (verb 4)

Changed 3 years ago by shio

Server conf file

comment:1 Changed 3 years ago by syzzer

I've seen similar behaviour with I603 (NDIS6 / new NDIS). In my case, I was using it as a client.

When connecting to the server everything seems to work just fine. After all the connection setup is completed, the TAP interface is configured. Somehow this fails, and the logs at verb 4 just show 'Closing TUN/TAP interface' (or something similar, I didn't store the logs) after which the process hangs and can no longer be terminated.

I did remove all TAP adapters, rebooted, freshly installed a TAP-adapter and verified it was an NDIS6 adapter. Problem persisted.

Since this was a production machine and I needed it at that point I didn't investigate further. I switched to I003 and everything worked like a charm again.

comment:2 Changed 3 years ago by cron2

  • Cc samuli added

comment:3 Changed 3 years ago by shio

Tested with the new 2.3.5 I601.
Same issue.

comment:4 Changed 3 years ago by mslootweg

I believe I also have this issue. (Hardware: Asus T100, fresh out the box)

In my case the client has the problem. The connetion succeeds, but it does not function correctly. Upon disconnect openvpn.exe reports "Closing TUN/TAP interface" and then becomes unkillable. I currently believe it is caused by the following bug in the NDIS6 tap driver: https://github.com/OpenVPN/tap-windows6/issues/3

A bugfix is available: https://github.com/OpenVPN/tap-windows6/commit/54efe89632a23aced27c625a5e5d5e477fd08675

In my case, building the fixed driver solves the issue completely. Unfortunatly, the fixed driver is really quite hard to load due to Windows driver signature enforcement. Every boot, I have to reboot to disable signature enforcement which requires entering the bitlocker key as the Asus T100 has secure boot enabled.

I would love to see this fix make it's way into a signed binary.

comment:5 Changed 3 years ago by samuli

I'm wrapping up updated tap-windows6 installers. Due to issues in tap-windows6 buildsystem it has taken a bit of time, but I should have a fixed version available early next week. Updated OpenVPN Windows client installers will come soon after that.

comment:6 Changed 3 years ago by samuli

Updated installer here:

Does this fix the issue?

comment:7 Changed 3 years ago by mslootweg

9.21.1 does indeed fix the issue completely for me. Thanks!

comment:8 Changed 3 years ago by shio

I also confirm, no issue so far with this new build :)
Thanks!

comment:9 Changed 3 years ago by samuli

Excellent! I'll make a new OpenVPN Windows installer release soon, probably early next week.

comment:10 Changed 3 years ago by samuli

New OpenVPN Windows installers with tap-windows-9.21.1 (build number I602) are out:

comment:11 Changed 3 years ago by samuli

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.