Opened 8 years ago

Closed 4 years ago

#219 closed Feature Wish (fixed)

man page could need improvements in the --keepalive section

Reported by: zmi Owned by: Samuli Seppänen
Priority: trivial Milestone: release 2.4
Component: Documentation Version: OpenVPN git master branch (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

I guess there's a small bug in the man page of openvpn regarding the "keepalive" example:

--keepalive n m

A helper directive designed to simplify the expression of --ping and --ping-restart in server mode configurations.

For example, --keepalive 10 60 expands as follows:

if mode server:

ping 10
ping-restart 120
push "ping 10"
push "ping-restart 60"

else

ping 10
ping-restart 60

Would openvpn really double the value for "ping-restart" in server mode, or shouldn't that read "ping-restart 60" instead "ping-restart 120"?

Change History (6)

comment:1 Changed 8 years ago by David Sommerseth

Component: Generic / unclassifiedDocumentation
Type: Bug / DefectFeature Wish

No, this is correct. The server side does 2*60 on ping-restart. A long while ago, I proposed this change - but it never got any attention since, so I never cared for following it up.

http://thread.gmane.org/gmane.network.openvpn.devel/2814

But that explains a little bit more how this happens. We can rather discuss how to make the documentation better at explaining this.

comment:2 Changed 8 years ago by David Sommerseth

Summary: man page wrong in OpenVPN 2.3_alpha1man page could need improvements in the --keepalive section

comment:3 Changed 7 years ago by Samuli Seppänen

Milestone: release 2.4
Owner: set to Samuli Seppänen
Status: newaccepted
Version: 2.3-beta / 2.3-RCgit master branch

214 is a duplicate of this.

comment:4 Changed 6 years ago by Gert Döring

Mr. Ticket Owner, how to proceed here...?

comment:5 Changed 5 years ago by Samuli Seppänen

Maybe we should just mention that "... in server mode the value of ping-restart is doubled; in the above example this translates to 120 (60*2)".

I can provide a patch if this approach is fine.

comment:6 Changed 4 years ago by Samuli Seppänen

Resolution: fixed
Status: acceptedclosed

This has been fixed a long time ago. Closing as fixed.

Note: See TracTickets for help on using tickets.