Opened 8 years ago

Closed 7 years ago

#214 closed Bug / Defect (duplicate)

Doubling of keepalive timeout option poorly documented in openvpn manpage

Reported by: matthijs Owned by: Samuli Seppänen
Priority: minor Milestone: release 2.4
Component: Documentation Version: OpenVPN git master branch (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

Hi,

the openvpn(8) manpage contains the following text:

1587 For example,
1588 .B \-\-keepalive 10 60
1589 expands as follows:
1590 
1591 .nf
1592 .ft 3
1593 .in +4
1594  if mode server:
1595    ping 10
1596    ping-restart 120
1597    push "ping 10"
1598    push "ping-restart 60"
1599  else
1600    ping 10
1601    ping-restart 60
1602 .in -4
1603 .ft
1604 .fi

I was going to suggest that the "120" in the ping-restart option should be "60", but then I checked the source and it seems the doubling of the timeout is actually happening:

http://openvpn.git.sourceforge.net/git/gitweb.cgi?p=openvpn/openvpn;a=blob;f=src/openvpn/helper.c;h=d9eef03bf45153ca6ead3d3fc95e520a9be73d65;hb=HEAD#l496

Perhaps it would be useful to explicitly document this in the manpage and also include some rationale (I tried finding the commit that introduced this behaviour, but some branching seems to have messed with the file's history)?

Change History (2)

comment:1 Changed 7 years ago by Samuli Seppänen

Milestone: release 2.4
Owner: set to Samuli Seppänen
Status: newaccepted

comment:2 Changed 7 years ago by Samuli Seppänen

Resolution: duplicate
Status: acceptedclosed

Closing as duplicate of #219.

Note: See TracTickets for help on using tickets.