Opened 3 months ago

Closed 6 weeks ago

#1423 closed Bug / Defect (fixed)

Surface Pro X (ARM64) unable to connect

Reported by: nekocentral Owned by:
Priority: major Milestone: release 2.5.4
Component: Generic / unclassified Version: OpenVPN 2.5.3 (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

Using the latest openvpn arm64 windows drivers and clients of the site I'm unable to connect to my server. I'm already tested the config on an X64 Windows system.

Config is setup for cert based auth.

When connecting using the GUI I get the following error.

2021-08-20 13:08:56 us=140000 OpenVPN 2.5.3 Windows-MSVC [SSL (OpenSSL)] [LZO] [LZ4] [PKCS11] [AEAD] built on Jun 17 2021
2021-08-20 13:08:56 us=140000 Windows version 10.0 (Windows 10 or greater) 64bit
2021-08-20 13:08:56 us=140000 library versions: OpenSSL 1.1.1k  25 Mar 2021, LZO 2.10
2021-08-20 13:08:56 us=140000 ERROR: Failed retrieving username or password
2021-08-20 13:08:56 us=140000 Exiting due to fatal error

When connecting by right clicking and selecting start client with this config i get the following

2021-08-20 12:49:45 NOTE: FlushIpNetTable failed on interface [50] {DEC5A799-5D68-4685-AF4B-4DAC2041E954} (status=5) : Access is denied.
2021-08-20 12:49:45 TUN: Setting IPv4 mtu failed: Access is denied.   [status=5 if_index=50]
2021-08-20 12:49:50 TEST ROUTES: 1/1 succeeded len=0 ret=1 a=0 u/d=up
2021-08-20 12:49:56 C:\WINDOWS\system32\route.exe ADD 45.144.219.208 MASK 255.255.255.255 192.168.0.1
2021-08-20 12:49:56 ROUTE: route addition failed using CreateIpForwardEntry: Access is denied.   [status=5 if_index=13]
2021-08-20 12:49:56 Route addition via IPAPI failed [adaptive]
2021-08-20 12:49:56 Route addition fallback to route.exe
2021-08-20 12:49:56 env_block: add PATH=C:\WINDOWS\System32;C:\WINDOWS;C:\WINDOWS\System32\Wbem
2021-08-20 12:49:56 ERROR: Windows route add command failed [adaptive]: returned error code 1
2021-08-20 12:49:56 C:\WINDOWS\system32\route.exe ADD 0.0.0.0 MASK 128.0.0.0 10.8.0.1
2021-08-20 12:49:56 ROUTE: route addition failed using CreateIpForwardEntry: Access is denied.   [status=5 if_index=50]
2021-08-20 12:49:56 Route addition via IPAPI failed [adaptive]
2021-08-20 12:49:56 Route addition fallback to route.exe
2021-08-20 12:49:56 env_block: add PATH=C:\WINDOWS\System32;C:\WINDOWS;C:\WINDOWS\System32\Wbem
2021-08-20 12:49:56 ERROR: Windows route add command failed [adaptive]: returned error code 1
2021-08-20 12:49:56 C:\WINDOWS\system32\route.exe ADD 128.0.0.0 MASK 128.0.0.0 10.8.0.1
2021-08-20 12:49:56 ROUTE: route addition failed using CreateIpForwardEntry: Access is denied.   [status=5 if_index=50]
2021-08-20 12:49:56 Route addition via IPAPI failed [adaptive]
2021-08-20 12:49:56 Route addition fallback to route.exe
2021-08-20 12:49:56 env_block: add PATH=C:\WINDOWS\System32;C:\WINDOWS;C:\WINDOWS\System32\Wbem
2021-08-20 12:49:56 ERROR: Windows route add command failed [adaptive]: returned error code 1
2021-08-20 12:49:56 Initialization Sequence Completed

Change History (3)

comment:1 Changed 3 months ago by nekocentral

Forgot to add
Device: Surface Pro X SQ1
OS: Windows 11 Beta Branch
OS Build: 22000.132

OpenVPN GUI build: 11.24.0.0
OpenVPN Build: 2.5.3
OpenVPN Build Date: Jun 17 2021
OpenSSL: 1.1.1k

comment:2 Changed 3 months ago by Selva Nair

Looks like the same issue as in #1418. If so, the fix will be in the next release (2.5.4).

See https://community.openvpn.net/openvpn/ticket/1418#comment:2

comment:3 Changed 6 weeks ago by Gert Döring

Milestone: release 2.5.3release 2.5.4
Resolution: fixed
Status: newclosed
Version: OpenVPN 2.5.3 (Community Ed)

@nekocentral: 2.5.4 should fix this for you. Please make sure to get the last installer (OpenVPN-2.5.4-I603-arm64.msi or I604) as 601+602 had some weird windows quirks.

I will now close the ticket (as I've tested this on ARM windows, and could reproduce the problem in 2.5.3 and confirmed the fix in 2.5.4). If it still fails, please reopen.

Note: See TracTickets for help on using tickets.