#1418 closed Bug / Defect (fixed)

Can't connect on ARM64 on Windows 11 22000.71

Reported by: jigglywiggly Owned by:
Priority: major Milestone: release 2.5.4
Component: Generic / unclassified Version: OpenVPN 2.5.1 (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

Hi, I have a surface Pro X. I can't connect on Windows 11 on arm64.

Viscosity actually warned me about being on insider builds and told me to use the legacy interface.

On openvpn 2.5.3 arm64 verison, when running with only the cert

2021-07-17 20:16:01 Note: Treating option '--ncp-ciphers' as  '--data-ciphers' (renamed in OpenVPN 2.5).
2021-07-17 20:16:01 DEPRECATED OPTION: --cipher set to 'AES-128-CBC' but missing in --data-ciphers (AES-128-GCM). Future OpenVPN version will ignore --cipher for cipher negotiations. Add 'AES-128-CBC' to --data-ciphers or change --cipher 'AES-128-CBC' to --data-ciphers-fallback 'AES-128-CBC' to silence this warning.
2021-07-17 20:16:01 OpenVPN 2.5.3 Windows-MSVC [SSL (OpenSSL)] [LZO] [LZ4] [PKCS11] [AEAD] built on Jun 17 2021
2021-07-17 20:16:01 Windows version 10.0 (Windows 10 or greater) 64bit
2021-07-17 20:16:01 library versions: OpenSSL 1.1.1k  25 Mar 2021, LZO 2.10
2021-07-17 20:16:01 ERROR: Failed retrieving username or password
2021-07-17 20:16:01 Exiting due to fatal error

Change History (6)

comment:1 Changed 13 months ago by jigglywiggly

To clarify, Viscosity did work when I used the legacy interface.
However I am not aware of such an option on the OpenVPN app. Since Viscosity uses OpenVPN is why I mentioned it,

comment:2 Changed 13 months ago by Selva Nair

Looks like the same issue as the one Gert found (is there a trac ticket for that?), and fixed in master and 2.5 (will be in 2.5.4). See https://patchwork.openvpn.net/patch/1871/

Essentially, while reading the management password, the process is failing to write the prompt to stderr because of an old bug which did not error on previous versions of Windows.

Last edited 13 months ago by Selva Nair (previous) (diff)

comment:3 in reply to:  2 Changed 13 months ago by jigglywiggly

Replying to Selva Nair:

Looks like the same issue as the one Gert found (is there a trac ticket for that?), and fixed in master and 2.5 (will be in 2.5.4). See https://patchwork.openvpn.net/patch/1871/

Essentially, while reading the management password, the process is failing to write the prompt to stderr because of an old bug which did not error on previous versions of Windows.

Great, thanks for letting me know.
This is out of the scope of the question, https://build.openvpn.net/downloads/snapshots/
I do not see any recent builds. If you or anyone knows how to find them(without having to compile it myself), that would be great. If not I do not mind waiting either for the official 2.5.4 release.

comment:4 Changed 12 months ago by hmartinez82

I can confirm that this is only happening with the ARM64 build in my Surface Pro X. I have another machine, with the exact same build number of Windows 11, but x64, and this bug does not appear.

Client 2.5.3
Windows 11 Build 22000.100

Last edited 12 months ago by hmartinez82 (previous) (diff)

comment:5 Changed 11 months ago by stipa

I cannot reproduce this on ASUS ARM64 Snapdragon, Windows 10 21H1 (19043).

We have GitHub? Actions artifacts, could you try those binaries? https://github.com/OpenVPN/openvpn/suites/3620135725/artifacts/87532262

comment:6 Changed 10 months ago by Gert Döring

Milestone: release 2.5.4
Resolution: fixed
Status: newclosed

We could reproduce this in the meantime and have put out 2.5.4 that works on ARM (I601+I602 have other bugs, so install I603 or I604, or 2.5.5).

Closing that ticket now, since it has a fix.

Note: See TracTickets for help on using tickets.