Opened 14 months ago

Last modified 12 months ago

#1422 assigned Feature Wish

bullseye

Reported by: vandman Owned by: Samuli Seppänen
Priority: major Milestone:
Component: Building / Compiling Version: OpenVPN git master branch (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords: bullseye, debian 11
Cc:

Description

Hi,
this is not a bug, but more a request.
There is no repo for bullseye (Debian 11) at the moment.
I tried to install it with other debian like repo. It does not work:

Tried with buster:

apt install openvpn3                      
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 openvpn3 : Dépend: libjsoncpp1 (>= 1.7.4) mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

tried with focal

apt install openvpn3                      
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 openvpn3 : Dépend: libjsoncpp1 (>= 1.7.4) mais il n'est pas installable
            Dépend: libprotobuf17 mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

tried with groovy

apt update                     
Atteint :1 http://nexus.sso.pp.minint.fr/repository/bullseye bullseye InRelease
Atteint :2 http://nexus.sso.pp.minint.fr/repository/bullseye bullseye-updates InRelease
Atteint :3 http://nexus.sso.pp.minint.fr/repository/bullseye bullseye-backports InRelease
Atteint :4 http://nexus.sso.pp.minint.fr/repository/bullseye-security-updates bullseye-security InRelease
Atteint :5 http://nexus.sso.pp.minint.fr/repository/bullseye-docker bullseye InRelease
Ign :6 http://nexus.sso.pp.minint.fr/repository/bullseye-openvpn3 groovy InRelease
Err :7 http://nexus.sso.pp.minint.fr/repository/bullseye-openvpn3 groovy Release
  404  Not Found [IP : 10.232.65.3 80]
Lecture des listes de paquets... Fait
E: Le dépôt http://nexus.sso.pp.minint.fr/repository/bullseye-openvpn3 groovy Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.

tried with hirsute

apt install openvpn3
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 openvpn3 : Dépend: libc6 (>= 2.33) mais 2.31-13 devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

nothing works.

Thanks
vandman

Change History (1)

comment:1 Changed 12 months ago by Gert Döring

Owner: set to Samuli Seppänen
Status: newassigned
Note: See TracTickets for help on using tickets.