Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#111 closed Bug / Defect (notabug)

PKCS12 key password change causes crash in windows

Reported by: lancethepants Owned by:
Priority: minor Milestone:
Component: Generic / unclassified Version: 2.2.0
Severity: Not set (if unsure, select this one) Keywords: PKCS12 Windows
Cc:

Description

When attempting to change the password on a PKCS12 key, it is unsuccessful and causes OpenVPN to crash in Windows.

Change History (10)

comment:1 Changed 3 years ago by dazo

Is it the core OpenVPN (openvpn.exe) which crashes, or is it the OpenVPN GUI?

comment:2 Changed 3 years ago by lancethepants

This error occurs when attempting to change the password using the gui, staring in RC1 and continued in RC2. I couldn't say however if it's the gui or the core causing the problem, I've just observed the issue and don't know how to diagnose it (I'm just a happy user with little to knowledge of C/C++.)
However, after looking into it further, it may be an issue with the OpenSSL binary packaged with OpenVPN. When attempting to change a pkcs12 key password with the openssl binary, running the command 'openssl pkcs12 -in my_cert.p12' to begin the process, crashes in the RC OpenSSL supplied binaries, but does not in beta5. Even running 'openssl version' causes an error.
The Openssl binary in the RC packages are 4 times smaller than that of the beta5, maybe a slimmer version to try to get the installer smaller. I then tried replacing the RC supplied OpenSSL binary with that from the beta5, to test if the same error occurs. I'm not even sure if you could replace binaries out like that, though I would guess that you could. With the OpenSSL binary from beta5 replacing the RC supplied binary, it still crashes, which I guess could bring it back either to the core or gui.

comment:3 Changed 3 years ago by lancethepants

The error returned when trying to change the pkcs key password in the gui is the following.

OPENSSL_Uplink(100FF000,08):no OPENSSL_Applink

comment:4 Changed 3 years ago by lancethepants

update:
I just tested changing the password using the ca, key, and cert combo instead of the pkcs12, and the error occurs here also.

comment:5 Changed 3 years ago by lancethepants

This issues still exists with 2.2 stable release.

comment:6 Changed 3 years ago by dazo

  • Keywords key password change removed
  • Version changed from 2.2-beta / 2.2-RC to 2.2.0

Are you changing the password via OpenVPN-GUI? If so, then the right place to report this bug is: http://sourceforge.net/tracker/?group_id=248281&atid=1327094

comment:7 Changed 3 years ago by dazo

OpenVPN-GUI on Windows, I meant to ask.

comment:8 Changed 3 years ago by lancethepants

Yes, under OpenVPN-GUI in Windows. I've now posted the bug on the provided link.

comment:9 Changed 3 years ago by dazo

  • Resolution set to notabug
  • Status changed from new to closed

Okay, then I'm closing this bug as 'notabug' as this is related to the OpenVPN-GUI project and not the core OpenVPN.

OpenVPN-GUI tracker for this ticket is located here:
http://sourceforge.net/tracker/?func=detail&aid=3299455&group_id=248281&atid=1327094

comment:10 Changed 3 years ago by dazo

  • Keywords Windows added
Note: See TracTickets for help on using tickets.