Opened 3 years ago

Closed 3 years ago

#991 closed Bug / Defect (duplicate)

iOS: VPN connection is on but no traffic after ~20-60 seconds with TCP

Reported by: Ozwel Owned by:
Priority: major Milestone:
Component: OpenVPN Connect Version: OpenVPN Connect for iOS v1.2.6
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

Hi, as reported here for 1.2.5: https://forums.openvpn.net/viewtopic.php?p=75653#p75653

Update to 1.2.6 did not resolve the issue.
It was working fine before 1.2.5
pivpn .ovpn file was generated by pivpn on Raspberry
iOS 11.2.2
iPhone 8

Logs attached (mode 5).

From 14h52: traffic is fine I can connect to one or two different websites.
From 14h53: couldn't load a web page in Safari or connect to WhatsApp?... No traffic at all. The logs don't seem to show anything relevant at this time (nothing happened in the logs).
At 14h55 still no change. I manually disconnected.

Attachments (1)

logs.txt (64.7 KB) - added by Ozwel 3 years ago.
logs

Download all attachments as: .zip

Change History (6)

Changed 3 years ago by Ozwel

Attachment: logs.txt added

logs

comment:1 Changed 3 years ago by Antonio

Does it happen after a burst?
Does it happen on TCP only?

If so, this is probably a duplicate of #984

comment:2 Changed 3 years ago by Antonio

Summary: VPN connection is on but no traffic after ~20-60 secondsiOS: VPN connection is on but no traffic after ~20-60 seconds with TCP

comment:3 Changed 3 years ago by Ozwel

Hi, after looking at other tickets, the problem seems to come from TCP/443 being used with iOS OpenVPN Connect client. I tried with UDP/another_port and it works all fine.

Other similar issues reported:

https://community.openvpn.net/openvpn/ticket/997
https://community.openvpn.net/openvpn/ticket/984

comment:4 in reply to:  1 Changed 3 years ago by Ozwel

Replying to ordex:

Does it happen after a burst?
Does it happen on TCP only?

If so, this is probably a duplicate of #984

Yes I tried using UDP and it worked perfectly (at least for the 1-2 connections I did right after).
Regarding the burst, I'd say "no" as the only thing I did before the traffic cut was loading 1 or 2 webpages in Safari (regular websites like anandtech or the verge).

Last edited 3 years ago by Ozwel (previous) (diff)

comment:5 Changed 3 years ago by Antonio

Resolution: duplicate
Status: newclosed

Ok, I think this is a duplicate of #984. TCP has definitely some problems and your case just falls into those.

Closing.

Note: See TracTickets for help on using tickets.