Opened 2 years ago

Closed 2 years ago

#986 closed Bug / Defect (duplicate)

iOS 1.2.6 - TCP transport stalls after traffic burst

Reported by: nemchin Owned by:
Priority: major Milestone:
Component: Generic / unclassified Version: OpenVPN Connect for iOS v1.2.6
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

VPN connection silently drops on traffic burst. Client log contains only CONNECTED event:

2018-01-17 11:27:02 PROTOCOL OPTIONS:
  cipher: BF-CBC
  digest: SHA1
  compress: LZO_STUB
  peer ID: -1
2018-01-17 11:27:02 Connected via NetworkExtensionTUN
2018-01-17 11:27:02 Per-Key Data Limit: 48000000/48000000
2018-01-17 11:27:02 LZO-ASYM init swap=0 asym=1
2018-01-17 11:27:02 Comp-stub init swap=0
2018-01-17 11:27:02 EVENT: CONNECTED @1.2.3.4:443 (1.2.3.4) via /TCPv4 on NetworkExtensionTUN/192.168.0.7/ gw=[/]

I'm going to test this over UDP transport.

Change History (2)

comment:1 Changed 2 years ago by janvier

Tested UDP works well on both Wi-Fi and 4G cellular network.

This issue just appear on TCP stream, whatever behind a proxy server or connect directly.

comment:2 Changed 2 years ago by Antonio

Resolution: duplicate
Status: newclosed

closing as duplicate of #984

Note: See TracTickets for help on using tickets.