Opened 2 years ago

Closed 2 years ago

#940 closed User question (notabug)

OpenVPN >2.4 Restart pause, 300 second(s) too high

Reported by: lexios Owned by:
Priority: minor Milestone: alpha 2.4
Component: tap-windows Version: OpenVPN 2.4.3 (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

Hello, a change implemented in OpenVPN client for Windows causes serious issues to our fleet since it takes 5 minutes for the OpenVPN service to kick in after a machine is woken from Sleep or Hibernation.

This didn't happen in the past versions.

According to Gert Doering, the issue is:

"Restart-delay is now exponentially growing - that is: it starts with
a quick restart, and if your server keeps not working, it goes up to
a maximum value, to avoid filling the log files all around with repetitive
messages."

http://openvpn-users.narkive.com/U1yOyWMk/openvpn-2-4-restart-pause-and-hup-bug
https://forums.openvpn.net/viewtopic.php?t=24878&p=72866

This was implemented by Selva Nair as "Exponentially back off on repeated connect retries" on 2.4alpha2.

https://community.openvpn.net/openvpn/wiki/ChangesInOpenvpn24

I believe that this change was implemented on 2.4 or later version and this is now a problem as there is no way to control this behavior and go back to the previous 2 seconds restart-pause.

Solution to this would a registry setting to control this resart-pause wait time.

Thank you

Change History (3)

comment:1 in reply to:  description Changed 2 years ago by tincantech

Replying to lexios:

this is now a problem as there is no way to control this behavior and go back to the previous 2 seconds restart-pause.

It is not a bug ..

https://www.mail-archive.com/openvpn-devel@lists.sourceforge.net/msg12318.html

Did you try --connect-retry yet ?

Last edited 2 years ago by tincantech (previous) (diff)

comment:2 Changed 2 years ago by selvanair

Priority: majorminor
Type: Bug / DefectUser question

I believe that this change was implemented on 2.4 or later version and this is now a problem as there is no way to control this behavior and go back to the previous 2 seconds restart-pause.

For 2 seconds pause with no back-off, use

--connect-retry 2 2

comment:3 Changed 2 years ago by selvanair

Resolution: notabug
Status: newclosed
Note: See TracTickets for help on using tickets.