Opened 7 years ago

Closed 18 months ago

#921 closed Bug / Defect (wontfix)

openvpn connect android BUG

Reported by: Zibri Owned by:
Priority: major Milestone:
Component: Generic / unclassified Version: OpenVPN 2.2.2 (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords: android, wifi_router, connect
Cc: plaisthos

Description

How to reproduce:

1) use openvpn connect to connect to a server
2) check that it works.
3) enable WIFI ROUTER in android.
4) connect to wifi router

Symptom:
the client is not able anymore to connect to the wifi router unless I disable openvpn
if the client was already connected, it will not work anyway.

Solution:
I think it has to do with DHCP and routing tables when wifi router is enabled.

I checked this in many ways.. I don't think is directly a problem in openvpn.. but maybe there is some work-around?

As of now I have to not use openvpn on the phone while wifi hotspot is on... and use openvpn on the device connected to it.
It would be nice to have openvpn running on the phone I use also as a hotspot.

Regards,
Zibri

Change History (1)

comment:1 Changed 18 months ago by Gert Döring

Cc: plaisthos added
Resolution: wontfix
Status: newclosed

Not sure this can be fixed in OpenVPN - this is happening on Android system level (which is, depending on Android version, all confused about the interactions between VPN API, WiFi? hotspot, and multiple users on the device).

Note: See TracTickets for help on using tickets.