Opened 4 years ago

Closed 4 years ago

#774 closed Bug / Defect (duplicate)

Issue with "register-dns"

Reported by: wla Owned by:
Priority: critical Milestone:
Component: Configuration Version: OpenVPN 2.3.12 (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords: register-dns opsi
Cc: walter.laub@…

Description

"register-dns" do:

  • C:\Windows\system32\net.exe stop dnscache
  • C:\Windows\system32\net.exe start dnscache
  • C:\Windows\system32\ipconfig.exe /flushdns
  • C:\Windows\system32\ipconfig.exe /registerdns

If the software "opsi" from http://uib.de/ is installed, "net.exe stop dnscache" hangs, because the service opsiclientd.exe depends from dnscache service. If we simulate this from a cmd, we saw that a question "did you will continue ..." wait for answer, but this all runs in background.
I attach a screenshot (the cmd ist manually started to illustrate the issue.

Change History (1)

comment:1 Changed 4 years ago by Gert Döring

Resolution: duplicate
Status: newclosed

duplicate of #775, more detail over there

Note: See TracTickets for help on using tickets.