Opened 3 years ago

Closed 3 years ago

#773 closed Feature Wish (fixed)

Drop support for EOL OpenSSL versions

Reported by: Steffan Karger Owned by:
Priority: major Milestone: release 2.5
Component: Crypto Version: OpenVPN 2.2.2 (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

In particular, drop support for OpenSSL 0.9.8 and 1.0.0. These have been EOL since 01-01-2016. Let's drop support for those versions in OpenVPN 2.5, and remove any code specific to those OpenSSL versions.

Change History (3)

comment:1 Changed 3 years ago by Steffan Karger

Type: Bug / DefectFeature Wish

comment:2 Changed 3 years ago by Gert Döring

This has been done, hasn't it?

comment:3 Changed 3 years ago by Steffan Karger

Resolution: fixed
Status: newclosed

Yes, it has:

commit 039a89c331e9b7998d8047ec72144097f7c5826a
Author: David Sommerseth <davids@…>
Date: Tue Apr 11 19:31:33 2017 +0200

Require minimum OpenSSL 1.0.1

Note: See TracTickets for help on using tickets.