Opened 10 years ago

Closed 9 years ago

#76 closed Bug / Defect (notabug)

Using port-share causes high CPU

Reported by: domingo Owned by:
Priority: major Milestone:
Component: Generic / unclassified Version: OpenVPN 2.1.0 / 2.1.1 (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

I've got a server that uses port-share to allow Openvpn to use 443/tcp together with a webserver.

Everytime I push non-openvpn traffic through openvpn (https traffic) the openvpn daemon uses 100% CPU and the syslog is filled with:

Tue Jan 18 06:30:55 2011 us=999640 TCP: accept(3) failed: Socket operation on non-socket (errno=88)

The webtraffic gets through to the webserver but it is very slow due to the high cpu load.

I'm using Ubuntu 10.04 (Lucid Lynx) 32-bit. I've disabled Apparmor.
Running version 2.1.0-1ubuntu1.1 but the problem is also present in the latest beta.

Change History (1)

comment:1 Changed 9 years ago by David Sommerseth

Resolution: notabug
Status: newclosed

It sounds like openvpn not able to connect to the remote service which should be behind to catch the non-openvpn traffic. And OpenVPN tries to get in touch with the host behind several times, which might cause the CPU load to increase.

For me it sounds like if it is a misconfiguration. Is the right IP address/hostname configured with --port-share? Is the firewall opened up for the local opevpn process to access this box?

Closing as 'notabug' for now. If you still are sure this is a bug, please feel free to re-open this bug. In that case we need configuration files and complete log files (use --verb 4 with openvpn) to see better what is happening.

Note: See TracTickets for help on using tickets.