Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#534 closed Bug / Defect (fixed)

Have to reinstall Tap driver every time I restart windows (Windows 7 64Bit)

Reported by: pitpat Owned by: Samuli Seppänen
Priority: minor Milestone:
Component: tap-windows Version: OpenVPN 2.3.6 (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords: TAP Restart Windows
Cc:

Description

I am running windows 7 64 bit Home Premium and Ultimate on several machines.
If I restart my machine I have to reinstall the TAP Virtual Ethernet Adapter (V9) each time before I can connect to my remote network.
If I do not and run OpenVPN Gui it says connected however the TAP network adapter says "Unidentified Network".

I normally leave my machine on standby so this is only rarely a problem for me. However, it is sometimes necessary to restart the machine.

I currently use OpenVPN 2.3.6-I602 Setup however I have tried older versions. I have just recently tried it on a clean install of Windows 7 64bit Ultimate with before and after all of the latest Updates/service packs installed.

For now I am going to set up a silent install of the TAP drivers everytime I restart windows. But this may not be the solution for everyone.

Change History (5)

comment:1 Changed 5 years ago by Gert Döring

Owner: set to Samuli Seppänen
Status: newassigned

comment:2 Changed 5 years ago by Samuli Seppänen

So you are saying that you can reproduce this issue 100% of the time on a Windows 7 64-bit installation which has no other (extra) software installed except OpenVPN 2.3.6?

comment:3 Changed 5 years ago by pitpat

Correct. When I had to reinstall my system due to a hardware failure I installed OpenVPN before installing anything else. Having had the problem for a while with 3 of my other systems I wanted to be sure that it was not a driver or other bit of software I had installed that was causing the problem. So last time I had to reinstall my system from scratch I installed OpenVPN 2.3.6-I602 first and it still had the same problem.

I assume it is something at the server end that is upsetting it (Otherwise everyone would be having problems). I don't really have access to the server side of things and they all use Linux so don't have the problem! I also don't have access to any other VPNs so can't really see if that is the problem.

The only two consistent things are the target server and that all my machines were installed from pre-service pack 1 Windows 7 CDs then updated to the latest version of windows using Windows update.

It is a very strange problem and any insights would be greatly appreciated.

comment:4 Changed 4 years ago by Samuli Seppänen

Resolution: fixed
Status: assignedclosed

I'm inclined to close this as "worksforme". Are you still experiencing this issue, and do you have any other insights? Nobody else has confirmed this problem so far, and it has been 18 months since this report was opened...

comment:5 Changed 4 years ago by pitpat

I have just upgraded to 2.3.12-I601 x86_64 and am no longer seeing the problem. So it looks like whatever it was has now been fixed. So "worksforme" too now. Thanks :-)

I suspect the cause was a setting server side that was somehow permanently upsetting the Windows client as the issue only occurred when I tried to connect to a specific client's server.

Note: See TracTickets for help on using tickets.