Opened 4 years ago

Closed 13 months ago

#455 closed Bug / Defect (worksforme)

Routing issues on iOS

Reported by: nino Owned by: Antonio
Priority: major Milestone:
Component: OpenVPN Connect Version:
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords: ios, routing
Cc:

Description

iOS Device testing - Iphone 5S/6
iOS Versions - 8.0.2
Connect Version - OpenVPN 1.0.5 build 177 (iOS 64-bit)

I have an open VPN instance running on an Ubuntu build. It is set to act as a gateway to clients so that all network traffic is routed through the VPN and the clients can view network resources behind the VPN.

The private lan is on 192.168.1.0/24 network
The VPN lan clients are on a 10.8.0.0/24 network

I have tested this issue using PC/Android/iOS

In situations where the hotspot lan is different from the private lan everything works as expected across all devices, traffic is routed through the gateway and the clients can see other devices.

In situations where the hotspot lan is on the same range as the private lan all the devices (PC/Android/iOS) route their traffic through the VPN as expected.

PC/Android can also see network resources behind the VPN however iOS is unable to see any other resources.

The following shows the traceroute on PC when connected to the VPN:

tracert 192.168.1.80
Tracing route to 192.168.1.80 over a maximum of 30 hops
  1   150 ms   153 ms   104 ms  MCP [10.8.0.1]
  2   307 ms    53 ms    53 ms  192.168.1.80
Trace complete.

The following shows the traceroute on iOS when connected to the VPN:

freetace to 192.168.1.80, 64 hops max, 52 byte packets
1 ************* Request timeout
2 ************* Request timeout
3 ************* Request timeout
4 ************* Request timeout

I dont believe this to be a server/iptables issue as everything works as expected on PC/Android, I have yet to test using a 32bit iOS device but I can do in a few days.

Attached is the config an routing information.

Attachments (4)

server_client_conf.txt (979 bytes) - added by nino 4 years ago.
Server / Client Openvpn conf
server_interfaces.txt (1.0 KB) - added by nino 4 years ago.
Server Interfaces
pc_routing_tables.txt (3.8 KB) - added by nino 4 years ago.
PC routing pre/post VPN connection
ios_routing_tables.txt (3.5 KB) - added by nino 4 years ago.
iOS Routing Tables

Download all attachments as: .zip

Change History (9)

Changed 4 years ago by nino

Attachment: server_client_conf.txt added

Server / Client Openvpn conf

Changed 4 years ago by nino

Attachment: server_interfaces.txt added

Server Interfaces

Changed 4 years ago by nino

Attachment: pc_routing_tables.txt added

PC routing pre/post VPN connection

Changed 4 years ago by nino

Attachment: ios_routing_tables.txt added

iOS Routing Tables

comment:1 Changed 4 years ago by Samuli Seppänen

Owner: set to jamesyonan
Status: newassigned

comment:2 Changed 4 years ago by nino

Just to update this

There are a few openvpn projects on Cydia, I tried one in particular "GuizmOVPN". I found that it also presents the same issues with routing, howver if I kill the connection and then rerun openvpnconnect my routing issues are solved. Perhaps GuizmOVPN is leaving some routes?

Nino

comment:3 Changed 4 years ago by Samuli Seppänen

Milestone: release 1.0.5

comment:4 Changed 13 months ago by Antonio

Owner: changed from jamesyonan to Antonio

Version 1.2.6 is on the AppStore?. Could you please test that and re-open this ticket is the issue is still there?

Thanks!

comment:5 Changed 13 months ago by Antonio

Resolution: worksforme
Status: assignedclosed
Note: See TracTickets for help on using tickets.