Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#454 closed Bug / Defect (fixed)

Windows ovpn connect client fails to create new VPN connections when the application log file is too large.

Reported by: daherrera101 Owned by: jamesyonan
Priority: major Milestone:
Component: OpenVPN Connect Version:
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

Discovered this today.

OpenVPN Connect Client for windows would not establish new vpn connections due to a "Error: cannot seek to end of --log file: C:
[REDACTED]" exception.

The log file in question was 6.22 gb in size. Each exception that was raised was, as you can guess, not written to a log due to the exception raised.

So why does the client not just create a new log file with a time stamp for record keeping? Is there a particular reason why this exception should be blocking versus non-blocking?

================
Client Version:
================
C:\Program Files (x86)\OpenVPN Technologies\OpenVPN Client\core>openvpn.exe --version
OpenVPNAS 2.3_ASC12b Windows-MSVC [SSL (OpenSSL)] [LZO] [NOSCRIPTS] [IPv6] built on Jun 5 2014
library versions: OpenSSL 1.0.1h 5 Jun 2014, LZO 2.06
Originally developed by James Yonan
Copyright (C) 2002-2010 OpenVPN Technologies, Inc. <sales@…>
Compile time defines: N/A

================
System Details:
================
C:\>systeminfo

Host Name: [REDACTED]
OS Name: Microsoft Windows 8.1 Enterprise
OS Version: 6.3.9600 N/A Build 9600
OS Manufacturer: Microsoft Corporation
OS Configuration: Member Workstation
OS Build Type: Multiprocessor Free
Registered Owner: [REDACTED]
Registered Organization: [REDACTED]
Product ID: [REDACTED]
Original Install Date: 9/11/2014, 3:56:26 PM
System Boot Time: 9/30/2014, 12:39:08 PM
System Manufacturer: LENOVO
System Model: 2352CTO
System Type: x64-based PC
Processor(s): 1 Processor(s) Installed.

[01]: Intel64 Family 6 Model 58 Stepping 9 GenuineIntel? ~2900 Mhz

BIOS Version: LENOVO G7ET92WW (2.52 ), 2/18/2013
Windows Directory: C:\Windows
System Directory: C:\Windows\system32
Boot Device: \Device\HarddiskVolume3
System Locale: en-us;English (United States)
Input Locale: en-us;English (United States)
Time Zone: (UTC-08:00) Pacific Time (US & Canada)
Total Physical Memory: 16,081 MB
Available Physical Memory: 2,230 MB
Virtual Memory: Max Size: 32,465 MB
Virtual Memory: Available: 18,007 MB
Virtual Memory: In Use: 14,458 MB
Page File Location(s): C:\pagefile.sys
Domain: [REDACTED]
Logon Server: [REDACTED]
Hotfix(s): 65 Hotfix(s) Installed.

[01]: KB2899189_Microsoft-Windows-CameraCodec?-Package
[02]: KB2894852
[03]: KB2894856
[04]: KB2918614
[05]: KB2919355
[06]: KB2919442
[07]: KB2920189
[08]: KB2926765
[09]: KB2931358
[10]: KB2931366
[11]: KB2937220
[12]: KB2938772
[13]: KB2939087
[14]: KB2939153
[15]: KB2939471
[16]: KB2939576
[17]: KB2949621
[18]: KB2950153
[19]: KB2954879
[20]: KB2955164
[21]: KB2956575
[22]: KB2957189
[23]: KB2958262
[24]: KB2959626
[25]: KB2959977
[26]: KB2961072
[27]: KB2962140
[28]: KB2962409
[29]: KB2964718
[30]: KB2965142
[31]: KB2965500
[32]: KB2965788
[33]: KB2966826
[34]: KB2966828
[35]: KB2967917
[36]: KB2969817
[37]: KB2971203
[38]: KB2971239
[39]: KB2971850
[40]: KB2972213
[41]: KB2972280
[42]: KB2973114
[43]: KB2973201
[44]: KB2973351
[45]: KB2973448
[46]: KB2975719
[47]: KB2976627
[48]: KB2976897
[49]: KB2977629
[50]: KB2977765
[51]: KB2978668
[52]: KB2979500
[53]: KB2979582
[54]: KB2980654
[55]: KB2981580
[56]: KB2981655
[57]: KB2987114
[58]: KB2988948
[59]: KB2989647
[60]: KB2990532
[61]: KB2990967
[62]: KB2993100
[63]: KB2993651
[64]: KB2995004
[65]: KB2998527

Network Card(s): 6 NIC(s) Installed.

[01]: Intel(R) 82579LM Gigabit Network Connection

Connection Name: Ethernet
Status: Media disconnected

[02]: Intel(R) Centrino(R) Ultimate-N 6300 AGN

Connection Name: Wi-Fi
DHCP Enabled: Yes
DHCP Server: 192.168.XXX.XXX
IP address(es)
[01]: 192.168.XXX.XXX
[02]: fe80::XXXX:XXXX:XXXX:XXXX

[03]: Bluetooth Device (Personal Area Network)

Connection Name: Bluetooth Network Connection
Status: Media disconnected

[04]: VMware Virtual Ethernet Adapter for VMnet1

Connection Name: VMware Network Adapter VMnet1
DHCP Enabled: No
IP address(es)
[01]: 192.168.XXX.XXX
[02]: fe80::XXXX:XXXX:XXXX:XXXX

[05]: VMware Virtual Ethernet Adapter for VMnet8

Connection Name: VMware Network Adapter VMnet8
DHCP Enabled: No
IP address(es)
[01]: 192.168.XXX.XXX
[02]: fe80::XXXX:XXXX:XXXX:XXXX

[06]: TAP Adapter OAS NDIS 6.0

Connection Name: Ethernet 2
DHCP Enabled: Yes
DHCP Server: 10.XXX.XXX.XXX
IP address(es)
[01]: 10.XXX.XXX.XXX
[02]: fe80::XXXX:XXXX:XXXX:XXXX

Hyper-V Requirements: VM Monitor Mode Extensions: Yes

Virtualization Enabled In Firmware: Yes
Second Level Address Translation: Yes
Data Execution Prevention Available: Yes

Change History (7)

comment:1 Changed 4 years ago by daherrera101

Let me know if you require any additional details.

Thanks,

Daniel

comment:2 in reply to:  description Changed 4 years ago by daherrera101

Ok so I am consistently reproducing this behavior on one of my systems.

Looks like somewhere in the sleep/wake cycle on the system a case gets triggered where IRP and/or packet queues are exhausted resulting in thousands of the following log entries being generated:

Mon Oct 06 16:37:09 2014 read from TUN/TAP : The I/O operation has been aborted because of either a thread exit or an application request. (code=995)

This explodes the log file triggering the issue described above in the ticket.

Let me know if you have any questions.

Thanks,

Daniel
References:

https://github.com/OpenVPN/tap-windows/blob/master/src/tapdrvr.c#L664

comment:3 Changed 4 years ago by LeoHeska

Hi.

I'm new to this community. Not really a c developer any more so I don't think I can or should try to fix this bug.

I am experiencing the same thing, just by using the OpenVPN client. This morning my log file was 16GB in size, full of those same errors. I tried upgrading to the latest version but that did not work. I deleted the log file, then I ran OpenVPN for maybe around an hour and the new log file was about 12GB in size.

My original installation of OpenVPN: openvpn-connect-2.0.8.106.msi
My reinstall: openvpn-install-2.3.5-I602-x86_64.exe

This kind of makes OpenVPN unusable for me. On top of everything else, when OpenVPN is running, it's using up a tremendous amount of CPU; battery drains, fan blows at max speed, system gets really hot (physical temperature).

I read about config changes having to do with not using TCP over TCP but I don't know how I could make such changes. Nor do I know if this is the problem.

Is this a bug someone can fix, and then release a patch?

I would really appreciate it.

comment:4 Changed 4 years ago by Samuli Seppänen

Component: Generic / unclassifiedOpenVPN Connect
Owner: set to jamesyonan
Status: newassigned

Assigning this to the correct person at OpenVPN Technologies.

comment:5 Changed 4 years ago by Samuli Seppänen

Version: 2.2.2

comment:6 Changed 3 years ago by novaflash

This was a bug in an older version of Connect Client that was shipped with 2.0.10. It didn't affect everyone; it only affected a few users depending on the environment where Connect Client ran. It was fixed in 2.0.11 and higher. Installing the Connect Client that ships with newer Access Servers will ensure the large log file gets deleted and the error doesn't show up again. So the correct resolution is to update the Access Server and then download and install the new Connect Client from that updated Access Server.

This ticket is being reviewed in an effort to clear out the unrelated tickets. Unrelated because this is not an open source issue, it is an issue for the commercial edition of OpenVPN called Access Server and its related OpenVPN Connect Client. In the future, if anyone wants to report a bug in the OpenVPN Access Server or Connect Client products, kindly go to www.openvpn.net and sign in there and use the support ticket system there.

Last edited 3 years ago by novaflash (previous) (diff)

comment:7 Changed 3 years ago by novaflash

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.