Opened 6 years ago

Closed 6 years ago

#416 closed Bug / Defect (invalid)

Android: connecting but not transferring data

Reported by: mfortini Owned by:
Priority: major Milestone:
Component: Generic / unclassified Version: 1.1.14
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

I upgraded to Android 4.4.3 (using CM11). My tunnel used to work. Right now I can connect, but while the number of bytes sent increases, the number of received bytes is stuck at 5.27kB forever.

The routes seem to be set up correctly, but I cannot ping even the server's peer IP address.

I understand my Android build is experimental, but I thought maybe this is 4.4.3 related and not something else.

I am willing to help understand the issue.

Change History (3)

comment:1 Changed 6 years ago by plaisthos

This seem a general problem with Cynogenmod 4.4.3 build. Normal 4.4.3 device are not affected. Which specific 4.4.3 device are you using?

To check if your routes are all installed you need to have a rooted devices:

iptables -t mangle -L -n
ip rule

ip ro sh ta <tablenumber>

comment:2 Changed 6 years ago by Samuli Seppänen

Does this issue persist on the latest Cyanogenmod releases? Certain Android versions had severe VPN API issues which were fixed later.

comment:3 Changed 6 years ago by Steffan Karger

Resolution: invalid
Status: newclosed

Not enough information to investigate, and reporter does not reply. Closing ticket.

Note: See TracTickets for help on using tickets.