Opened 5 years ago

Closed 4 years ago

#393 closed Bug / Defect (worksforme)

Error occured installing tap device driver

Reported by: FrancoisC Owned by: Samuli Seppänen
Priority: major Milestone: release 2.3.6
Component: tap-windows Version: OpenVPN 2.3-beta / 2.3-RC (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords: tap window error
Cc:

Description

Hi,

I've been digging into some similar reports and blogs, but none of them have solved my problem.

While installing OpenVPN 2.3.3 64 bit version on a Windows 7 laptop, I get this (seemed to be famous) error message:
"An error occured installing tap device driver"

I've looked at bu report #266, and tried a few things:

All gave me the exact same error.

Also,

  • calling the addtap.bat script in admin mode give me the following error:
C:\Windows\system32>rem Add a new TAP virtual ethernet adapter

C:\Windows\system32>"C:\Program Files\TAP-Windows\bin\devcon.exe" install "C:\Pr
ogram Files\TAP-Windows\driver\OemWin2k.inf" tap0901
Device node created. Install is complete when drivers are installed...
Updating drivers for tap0901 from C:\Program Files\TAP-Windows\driver\OemWin2k.i
nf.
devcon.exe failed.

C:\Windows\system32>pause

I've seen on report #266 there might be an issue with VMWare being installed. It is my case. But it's not clear from this report this is really an issue or if there is a workaround.

Anyone has a clear, comprehensive, working solution or workaround ?

Regards
François

Change History (7)

comment:1 Changed 5 years ago by francoisC

Any update, help would be appreciated.
Regards
François

comment:2 Changed 5 years ago by Gert Döring

Owner: set to Samuli Seppänen
Status: newassigned

Anything in the system logs when this happens?

Samuli, any ideas where to look?

(I'm inclined to classify this as "something is weird with the laptop in question" as it worked for all my test cases on Win7, but since this is happening every now and then for different people, we might want to investigate again)

comment:3 Changed 5 years ago by Gert Döring

Milestone: release 2.3.3release 2.3.5

Oh, and this won't make 2.3.4 whatever it is, at least not -I001 -> setting milestone 2.3.5

comment:4 Changed 5 years ago by Samuli Seppänen

The problem with devcon.exe errors is that they are hopelessly generic.

FrancoisC: can you do some debugging as outlined here?

comment:5 Changed 4 years ago by Samuli Seppänen

FrancoisC: please try the latest OpenVPN installer (2.3.5-I602). If the problem still persists please follow the tap-windows debugging instructions.

comment:6 Changed 4 years ago by Samuli Seppänen

Milestone: release 2.3.5release 2.3.6

comment:7 Changed 4 years ago by Samuli Seppänen

Resolution: worksforme
Status: assignedclosed

No response from the bug reporter in 7 months. No complaints from anyone else. Closing this as "worksforme".

Note: See TracTickets for help on using tickets.