Opened 7 years ago

Closed 7 years ago

#266 closed Bug / Defect (worksforme)

cannot install TAP driver on windows 7

Reported by: edx Owned by: Samuli Seppänen
Priority: minor Milestone:
Component: tap-windows Version: OpenVPN 2.3.2 (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords: windows
Cc:

Description

I cannot install TAP driver version 9.9.2 on Windows 7 (64 bit machine). The problem is that installer cannot create network adapter - result is:
---
C:\Program Files\TAP-Windows\bin>rem Add a new TAP virtual ethernet adapter

C:\Program Files\TAP-Windows\bin>"C:\Program Files\TAP-Windows\bin\devcon.exe" install "C:\Program Files\TAP-Windows\driver\OemWf?" tap0901
Device node created. Install is complete when drivers are installed...
Updating drivers for tap0901 from C:\Program Files\TAP-Windows\driver\OemWin2k.inf.
devcon.exe failed.

---
after investigation I discovered that this driver is to be installed with the Class-GUID={4d36e972-e325-11ce-bfc1-08002be10318} the same as the VMNET1 driver of the VmWare? workstation (version 9.0.0 build-812388) which I have also on my PC.

Question is whether TAP driver can be delivered with installer that generates the GUID during the installation phase to avoid conflicts with installed base of the PC. Other question is it can be changed only in .inf file without touching .cat and .sys files.

Change History (7)

comment:1 Changed 7 years ago by Samuli Seppänen

Look here:

All devices of the same class share the same Class-GUID, so the problem must lie elsewhere. Can you run devcon.exe manually as described here to help figure out where the problem is?

comment:2 Changed 7 years ago by Samuli Seppänen

Component: Generic / unclassifiedInstallation
Milestone: release 2.3
Owner: set to Samuli Seppänen
Priority: blockerminor
Status: newassigned

comment:3 Changed 7 years ago by jfritz

I had the exact same problem on Windows 8.1 pro 64 bit with openvpn 2.3.2.

Using the "Install new TAP..." option in the start menu rendered this exact same error message, even when run with administrator privileges.

I downloaded a fresh tap-windows-9.9.2_3.exe from the website and installed using that. It was successful. Not sure why this worked.

comment:4 Changed 7 years ago by Samuli Seppänen

Keywords: windows added; TAP install GUID conflict removed
Milestone: release 2.3
Version: 2.3.02.3.2

Jfritz: There was a problem in the TAP-Windows driver signature in earlier Windows builds of 2.3.2, which is fixed in the latest one (which includes the tap-windows-9.9.2_3.exe you mentioned). That's one possible reason why installing TAP-Windows separately worked for you.

Also, the error messages from devcon.exe are pretty much useless, so having the "exact same" error message does not help much (been there). Anybody else having this issue, or shall I close this bug report?

comment:5 Changed 7 years ago by Samuli Seppänen

Component: Installationtap-windows

comment:6 Changed 7 years ago by Samuli Seppänen

Added some generic tap-windows installation debugging documentation here.

I will close this bug report now. If you are experiencing tap-windows installation problem, make sure you've tried the steps outlined here. If the tap-windows issues still persist, please file a new bug report.

comment:7 Changed 7 years ago by Samuli Seppänen

Resolution: worksforme
Status: assignedclosed
Note: See TracTickets for help on using tickets.