Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#378 closed Bug / Defect (notabug)

DNS push not working on iOS7

Reported by: oliver.neumann Owned by:
Priority: blocker Milestone:
Component: OpenVPN Connect Version:
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

Reproducable on iPhone 5s with iOS7:

Our Sophos UTM pushes DNS config with the follwing command:

[dhcp-option] [DNS] [XXX.XXX.XXX.XXX]

VPN connection itself works but no DNS, so only IP-based actions are successful. DNS is not set.

With iOS6 it was not problem at all.

Problem has been reported in some forum threads:

https://forums.openvpn.net/topic15334.html
https://forums.openvpn.net/topic15066.html
https://supportforums.cisco.com/discussion/12009791/iphone-ios7-not-using-split-dns-when-cellular-connection

I'm using OpenVPN Connect 1.0.4 (latest in Apple Store)

Change History (5)

comment:1 Changed 5 years ago by hbamacdade

Reproducible on all of our iPhones and iPads running iOS 7, whether using cellular or foreign WiFi? connections.
Our WatchGuard? XTM pushes DNS config with the same command as the original poster.

iPhone 4S, 5
iPad 2, 3, 4, and Air

OpenVPN Connect version 1.0.4

Settings work fine on Windows and Android devices, so far as we've experienced.

comment:2 Changed 5 years ago by oliver.neumann

For us it works now. Was a additional setting (domain search), which needed to be disabled (or left blank).

Since we did this, VPN is working fine.

comment:3 Changed 5 years ago by hbamacdade

This workaround does not seem to adversely affect the behavior of windows/android clients on my managed systems.

Last edited 5 years ago by hbamacdade (previous) (diff)

comment:4 Changed 4 years ago by krzee king

Resolution: notabug
Status: newclosed

comment:5 Changed 4 years ago by krzee king

Looks like you guys found a solution in the settings. Good job!

Note: See TracTickets for help on using tickets.