Opened 4 months ago

Closed 4 months ago

#1473 closed User question (notabug)

VPN connection didn't became as default gateway by default

Reported by: mvgavrilov Owned by:
Priority: major Milestone:
Component: Generic / unclassified Version:
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

According to documentation https://community.openvpn.net/openvpn/wiki/IgnoreRedirectGateway VPN connection must not become a gateway only when a parameter is specified 'pull-filter ignore redirect-gateway'.

But I has config without 'pull-filter ignore redirect-gateway' and this connection not became as default gateway.

It a bug?

Here is my .ovpn file:

tls-client
dev tun
proto udp4
remote employer.com 607
push-peer-info
auth-user-pass
reneg-sec 86400
remote-cert-tls server
client-cert-not-required
key-direction 1
<ca>
-----BEGIN CERTIFICATE-----
Cut the certificate
-----END CERTIFICATE-----
</ca>
<tls-auth>
#
# 2048 bit OpenVPN static key
#
-----BEGIN OpenVPN Static key V1-----
Cut the key
-----END OpenVPN Static key V1-----
</tls-auth>

Change History (1)

comment:1 Changed 4 months ago by Gert Döring

Resolution: notabug
Status: newclosed

There is no redirect-gateway in your config, so OpenVPN will not redirect the gateway. If the server is pushing one, we can't see it, because there is no log file included (verb 3).

pull-filter is an expert option to ignore/reject options configured on the OpenVPN server and pushed towards the clients if you do not want that - but if there is no option there to start with, there is nothing to ignore.

Long story short: if you want a redirected default gateway, add redirect-gateway def1 to your client config (or have it pushed from the server).

Generally speaking, this bug tracker is more intended for "is this a bug?" type questions. User questions are better fit in the OpenVPN Forum, or on the openvpn-users mailing list.

Note: See TracTickets for help on using tickets.