Opened 11 months ago

Last modified 3 months ago

#1328 assigned Bug / Defect

iOS: connection unreliable after wake

Reported by: Hunterx1 Owned by: OpenVPN Inc.
Priority: major Milestone:
Component: OpenVPN Connect Version: OpenVPN Connect for iOS v3.0.2
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

After upgrading to iOS 14.0, OpenVPN connect 3.2.0 has the following behaviors:
1) Remains connected, but no internet connectivity.
2)Can connect to local network, but nothing to the internet.
3)No logs at all for any issues, and no Analytics.
4)works normally after connected, but breaks after wake?

This happened while connected to a home OpenVPN server. LAN was accessible, but the internet was not.

This also happened while connected to a paid PIA OpenVPN server. The connecting appears alive, but no internet.

I also tested using the PIA application which uses OpenVPN. This app functions as it should.

I can only guess that the OpenVPN app has some issues with the iOS 14 update.

Attachments (1)

openvpn.txt (31.1 KB) - added by Hunterx1 11 months ago.

Download all attachments as: .zip

Change History (5)

Changed 11 months ago by Hunterx1

Attachment: openvpn.txt added

comment:1 Changed 11 months ago by Hunterx1

The reconnect after wake is in the log, but I can’t find the issues with it. I attached the log. It connects just fine after wake, but can’t access the internet. I verified that I was able to access my local LAN from the LTE using the connection, but at the same time not able to access the internet. Same behavior with PIA.

comment:2 Changed 11 months ago by Hunterx1

This issue appears to be affecting the seamless tunnel feature. It seems to work after turning it off.

comment:3 Changed 7 months ago by Gert Döring

Owner: changed from yuriy to denys
Status: newassigned

comment:4 Changed 3 months ago by Antonio

Owner: changed from denys to OpenVPN Inc.
Note: See TracTickets for help on using tickets.