Opened 2 years ago

Closed 2 years ago

#1326 closed Bug / Defect (fixed)

problem with openvpn debian package upgrade (beta3 to beta4)

Reported by: Gert Döring Owned by: Samuli Seppänen
Priority: major Milestone: release 2.5
Component: Packaging Version:
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords: debian, beta4


Forwarding a report I received by mail:

We run multiple instances openvpn@*.services with systemd. Upgrading the
openvpn debian package fails in the following way (tested with 2.5 beta4):

openvpn processes keep running and tap interfaces are still up. But the
openvpn service is stopped. So neither starting nor stopping openvpn
service works in this situation. So I have to kill/delete them manually
or just reboot.

I analyzed that "invoke-rc.d openvpn cond-restart" is invoked in
postinst which leads to the situation described above. BTW: I also
tested "systemctl restart openvpn" which works.

Perhaps you want to adopt the following commits:

Change History (6)

comment:1 Changed 2 years ago by Samuli Seppänen

Thanks for the report!

Which operating system version does this happen on?

comment:2 Changed 2 years ago by Gert Döring

"Oh, sorry. Das ist Debian stable = Debian 10 (Buster)."

comment:3 Changed 2 years ago by Samuli Seppänen

Test packages that should fix this issue:

If you can get these tested today or morning-ish CET that would be good.

comment:4 Changed 2 years ago by Gert Döring

root@ovpn-mgmt-04:~# dpkg -i openvpn_2.5-rc1-buster0_amd64.deb
(Reading database ... 50392 files and directories currently installed.)
Preparing to unpack openvpn_2.5-rc1-buster0_amd64.deb ...
Unpacking openvpn (2.5-rc1-buster0) over (2.5-beta4-buster0) ...
Setting up openvpn (2.5-rc1-buster0) ...
A reboot is required to replace the running openvpn.
Please reboot the system as soon as possible.
Processing triggers for systemd (241-7~deb10u4) ...
Processing triggers for man-db (2.8.5-2) ...

Works. The systemd services are still active (running).

So you can manually run "systemctl restart openvpn" afterwards or just reboot.
Everything ok, thanks!

comment:5 Changed 2 years ago by Samuli Seppänen

Thanks for testing the fixed packages! Also thanks for the pointers to the fix. I could not use those fixes as-is, as they were for Debian Unstable, but I cherry-picked the relevant parts.

comment:6 Changed 2 years ago by Samuli Seppänen

Resolution: fixed
Status: assignedclosed

Fixed in OpenVPN 2.5-rc1 packages for Debian 10 that were just pushed to the apt repo.

Note: See TracTickets for help on using tickets.