Opened 21 months ago

Closed 21 months ago

Last modified 21 months ago

#1151 closed User question (notabug)

Unable to forward ethernet frame at tap mode

Reported by: bipulkumar Owned by:
Priority: major Milestone:
Component: Networking Version: OpenVPN 2.4.4 (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

Hi,
In a tap mode, ethernet frame is unable to forward in private networks.
Please find the diagram with details.

I'm using OpenVPN 2.4.4 x86_64-pc-linux-gnu

https://pastebin.com/raw/huLHrq3R

Change History (2)

comment:1 Changed 21 months ago by Gert Döring

Resolution: notabug
Status: newclosed
Type: Bug / DefectUser question
Version: OpenVPN 2.4.4 (Community Ed)

Your diagram is not making sense. The diagram shows "tun" and the config shows "--dev tun", but the routing table shows "tap0" - make up your mind. I'd stay with "tun" as your config shows, though, as you do not need tap unless you very clearly know *why*.

Then, you need routes toward the tap interface on the clients (otherwise, packets to "D" will not go into the tunnel) and most likely "D" will also need a route back.

This is all basic routing, so not really something for our bug tracker - look here to get started (read it thoroughly): http://www.secure-computing.net/wiki/index.php/OpenVPN/Routing - and if that does not help, the openvpn forum is better suited for user-to-user advice.

comment:2 Changed 21 months ago by bipulkumar

Hi Gert,

Thank you very much, for making it clear. I'm sorry i have given a wrong diagram here, it was for tun and works well.

Please find the diagram for tap https://pastebin.com/raw/fje2RFhc

I have mentioned every steps to establish connectivity from A to D, but it *fails*.
And once again thanks for your basic routing link, it might helps me to learn.

Thank you
Bipul


Last edited 21 months ago by bipulkumar (previous) (diff)
Note: See TracTickets for help on using tickets.