Opened 2 years ago

Closed 2 years ago

Last modified 16 months ago

#1076 closed Bug / Defect (fixed)

iOS 12: OpenVPN disconnects after switching to another app

Reported by: mbierman Owned by:
Priority: critical Milestone:
Component: Generic / unclassified Version: OpenVPN Connect for iOS v1.2.9
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

iOS 12 public beta
latest OpenVPN
VPN UDPv4

  1. Start/open an OpenVPN connection from inside the OpenVPN APP.
  2. Switch to any app or home screen.

Result; VPN connection drops immediately. The VPN indicator disappears on the status bar and if you return to the OpenVPN app it shows the connection stopped.

Expected: the connection should not be interrupted by backgrounds get the OpenVPN app.

Change History (29)

comment:1 Changed 2 years ago by Antonio

Summary: OpenVPN disconnects after switching to another appiOS 12: OpenVPN disconnects after switching to another app

Thanks for the report, however this is an iOS 12 issue and there is not much we can do about it. Apple is aware of the problem and hopefully it will fix it soon.

I'll keep the ticket open just to prevent other people from opening similar issues.

comment:2 Changed 2 years ago by smchase

I have the same problem on iOS 12 DB3. It also doesn't work if you enable from settings.

comment:3 Changed 2 years ago by hunterx1

watching for updates.

comment:4 Changed 2 years ago by sexton

watching for updates

comment:5 Changed 2 years ago by Antonio

to all the people writing in this post: please report the issue to Apple to ensure they assign it the right severity/priority. This is the only thing we can do as of now.

comment:6 Changed 2 years ago by mbierman

FYI I installed the iOS 12 public beta (v6) today and the issue remains.

comment:7 Changed 2 years ago by hunterx1

I heard from various sources that issue is fixed with OpenVPN Connect 3.0 beta. I can't personally confirm because I am not included in the beta. I'm not going to, but if you are on the iOS 12 beta already, I suggest applying for the OpenVPN beta program to get access to it on the testflight app.

comment:8 Changed 2 years ago by Antonio

As mentioned several times the problem is in iOS, not in the app, therefore a simple upgrade of the app won't solve the issue.

@hunterx1 did you hear this from any OpenVPN, Inc. official source?

comment:9 in reply to:  8 ; Changed 2 years ago by hunterx1

Replying to Antonio:

As mentioned several times the problem is in iOS, not in the app, therefore a simple upgrade of the app won't solve the issue.

@hunterx1 did you hear this from any OpenVPN, Inc. official source?

Nothing official. This is just one of a few sources i found so far: https://forums.openvpn.net/viewtopic.php?f=36&t=26777

and this: https://forums.macrumors.com/threads/ovpn-workaround-for-synology-based-vpn-server.2130501/

Last edited 2 years ago by hunterx1 (previous) (diff)

comment:10 in reply to:  8 ; Changed 2 years ago by mbierman

Replying to Antonio:

As mentioned several times the problem is in iOS, not in the app, therefore a simple upgrade of the app won't solve the issue.

@hunterx1 did you hear this from any OpenVPN, Inc. official source?

How do we know this for certain? In any case, if Apple does make a fix in iOS it will need to be validated by OpenVPN developers to ensure that things work properly. I have reported this to Apple (I don't know if outside devs can see these, but it is #4410352).

comment:11 in reply to:  9 ; Changed 2 years ago by Antonio

Replying to hunterx1:

Replying to Antonio:

As mentioned several times the problem is in iOS, not in the app, therefore a simple upgrade of the app won't solve the issue.

@hunterx1 did you hear this from any OpenVPN, Inc. official source?

Nothing official. This is just one of a few sources i found so far: https://forums.openvpn.net/viewtopic.php?f=36&t=26777

and this: https://forums.macrumors.com/threads/ovpn-workaround-for-synology-based-vpn-server.2130501/

Unfortunately people are just mixing information here. As you can see nobody explicitly says that the "disconnection when app goes to background" issue is solved.

However, since I am currently the one following up with Apple, I can tell you that today I got this response:

It has not been determined how or when the issue will be resolved.
The original report on this issue, Bug ID 39800424, is still under investigation.
We will notify you when it is closed.
Please note that you will not be able to directly view the original report in order to keep its information confidential.
We will do our best to keep you informed as new information becomes available.
Please check release notes regularly for changes affecting this issue.

So as we can see Apple hasn't made any progress yet and the bug remains unresolved.
The only thing we can do on our side is to wait for Apple or create additional bug reports to them (to bump their priority - even though this might not be the best course of action as this will also east their time).

comment:12 in reply to:  10 Changed 2 years ago by Antonio

Replying to mbierman:

I have reported this to Apple (I don't know if outside devs can see these, but it is #4410352).

No, we are not able to see that, but glad that you opened a ticket with them.

comment:13 in reply to:  11 Changed 2 years ago by mbierman

Thanks. Apple is not being very committal about this, but that isn't surprising I guess during a beta. It seems astonishing that they wouldn't fix VPN though. Good to know they acknowledge the problem. I reported it back in beta 4 and again in beta 6. I guess we can just sit back and wait for now. :( Thanks again for the update and the attention in the event that Apple says there is anything OpenVPN has to fix (e.g. they changed an API or something.)

Replying to Antonio:

Replying to hunterx1:

Replying to Antonio:

As mentioned several times the problem is in iOS, not in the app, therefore a simple upgrade of the app won't solve the issue.

@hunterx1 did you hear this from any OpenVPN, Inc. official source?

Nothing official. This is just one of a few sources i found so far: https://forums.openvpn.net/viewtopic.php?f=36&t=26777

and this: https://forums.macrumors.com/threads/ovpn-workaround-for-synology-based-vpn-server.2130501/

Unfortunately people are just mixing information here. As you can see nobody explicitly says that the "disconnection when app goes to background" issue is solved.

However, since I am currently the one following up with Apple, I can tell you that today I got this response:

It has not been determined how or when the issue will be resolved.
The original report on this issue, Bug ID 39800424, is still under investigation.
We will notify you when it is closed.
Please note that you will not be able to directly view the original report in order to keep its information confidential.
We will do our best to keep you informed as new information becomes available.
Please check release notes regularly for changes affecting this issue.

So as we can see Apple hasn't made any progress yet and the bug remains unresolved.
The only thing we can do on our side is to wait for Apple or create additional bug reports to them (to bump their priority - even though this might not be the best course of action as this will also east their time).

comment:14 Changed 2 years ago by mrdindon

Testing on OpenVPN 3.0.0 (693) this morning..
The connection seams to stay alive even when changing app but I'm unable to contact anything on my vpn network using any other app. Returning to OpenVPN connect app, the connection seams to have survive..

comment:15 Changed 2 years ago by mbierman

Testing OpenVPN 1.2.9 on the latest iOS PUBLIC 12 beta 7 (released today) things have not changed (VPN connection disconnects when switching to another app or home screen.

Last edited 2 years ago by mbierman (previous) (diff)

comment:16 Changed 2 years ago by mbierman

Testing OpenVPN 1.2.9 on the latest iOS 12 PUBLIC beta 8 (released today) things have not changed (VPN connection disconnects when switching to another app or home screen.

Last edited 2 years ago by mbierman (previous) (diff)

comment:17 Changed 2 years ago by mbierman

Testing OpenVPN 3.0 (public release) on the latest iOS 12 PUBLIC beta seems to resolve this issue.

comment:18 Changed 2 years ago by Antonio

Resolution: fixed
Status: newclosed

Other testers have also reported the problem as being fixed in the latest public release.
I am closing this; feel free to re-open if the same issue should persist.

comment:19 Changed 2 years ago by samqa900

as of iOS 12 Golden Master release , both the updated OpenVPN Connect in the app store and the beta one have this bug.

I think the ticket should be reopened.

Last edited 2 years ago by samqa900 (previous) (diff)

comment:21 in reply to:  20 ; Changed 2 years ago by samqa900

Replying to mbierman:

Related to https://community.openvpn.net/openvpn/ticket/1107

no for me the VPN connection keep disconnecting with a Popup Message in the app "There was an error attempting to connect to the selected server" with Cancel and Retry options.

and I've to go to the app or iOS Settings app manually to reconnect , and it will keep looping in disconnection and keep repeating.

Last edited 2 years ago by samqa900 (previous) (diff)

comment:22 Changed 2 years ago by mbierman

Fair enough. That is not happening to me. I get a successful connection but no traffic is able to flow through at all.

comment:23 Changed 23 months ago by JustinJack

i am using this for my site's simple landing page: WhatsApp Status but one of little bug is being issued while i want to openvpn.

comment:24 in reply to:  21 Changed 22 months ago by softd

Replying to samqa900:
Hello samqa900, I think your problem is a different one than the one handled here. I have the same message appearing with the OpenVPN App Version 3.x with one customer. While I was still using the old app with Version 1.2.9 I used to receive a message that MD5 support will be dropped at the end of April 2018. Now, with Version 3.x it obviously is dropped and therefore I receive this same message as you do. If you search your log messages you will find some hints here. The version 3.x app is working fine for me with another customer.

In my logs it says at one point "VERIFY FAIL -- The certificate is signed with an unacceptable hash" and "signed using : RSA with MD5".

Replying to mbierman:

Related to https://community.openvpn.net/openvpn/ticket/1107

no for me the VPN connection keep disconnecting with a Popup Message in the app "There was an error attempting to connect to the selected server" with Cancel and Retry options.

and I've to go to the app or iOS Settings app manually to reconnect , and it will keep looping in disconnection and keep repeating.

comment:25 Changed 22 months ago by softd

My Problem here is that after I updated the OpenVPN app on my iPhone to Version 3.x I could no longer connect to my customer with certificates signed with MD5. So, I decided to stick to Version 1.2.9 on my iPad. But now, after updating both devices to iOS 12, the OpenVPN app (v 1.2.9) on my iPad is not working correctly anymore and therefore I can no longer connect to this customer with both devices.

OpenVPN app 1.2.9 with iOS 11: all working fine, but getting "MD5 end of support" msg
OpenVPN app 3.x with iOS 11: can no longer connect to customer with MD5 signed certificates
OpenVPN app 1.2.9 with iOS 12: drops connection as soon as the app goes to the background (what this discussion is about)
OpenVPN app 3.x with iOS 12: can no longer connect to customer with MD5 signed certificates

So, as Apple probably won't fix their iOS in order to get OpenVPN 1.2.9 again, I will not be able to connect to the one customer anymore except I could convince them providing new certificates with a stronger signature.

By the way, it's probably not the case that Apple would have to fix their iOS, but rather that OpenVPN 1.2.9 ist not compatible to iOS 12 anymore.

Last edited 22 months ago by softd (previous) (diff)

comment:26 in reply to:  25 Changed 22 months ago by Antonio

Replying to softd:

By the way, it's probably not the case that Apple would have to fix their iOS, but rather that OpenVPN 1.2.9 ist not compatible to iOS 12 anymore.

To clarify, it turned out that this was a bug in OpenVPN Connect triggered by a different behaviour in iOS 12. The issue has been fixed in newer releases of OpenVPN Connect, therefore upgrading if definitely the only way to get rid of the issue.

So, as Apple probably won't fix their iOS in order to get OpenVPN 1.2.9 again, I will not be able to connect to the one customer anymore except I could convince them providing new certificates with a stronger signature.

You should really convince your customer to change the way they sign their certificates as MD5 is totally insecure at the moemnt when it comes to this particular use case.

This is exactly why MD5 support was dropped.

comment:27 Changed 22 months ago by JustinJack

Spam

Last edited 16 months ago by Eric Crist (previous) (diff)

comment:28 Changed 22 months ago by softd

well, why do they not just let me continue use these MD5 certs anymore in OpenVPN app version 3? they could add a Setting for this...

comment:29 in reply to:  23 Changed 16 months ago by JustinJack

Spam

Last edited 16 months ago by Eric Crist (previous) (diff)
Note: See TracTickets for help on using tickets.