Opened 2 years ago

Last modified 2 years ago

#1019 new Bug / Defect

iOS: used 2.1GB cellular data this period

Reported by: shammalammadingdong Owned by: Antonio
Priority: major Milestone:
Component: OpenVPN Connect Version: OpenVPN Connect for iOS v1.2.7
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

OpenVPN

iPhone 6S, iOS 11.2.5, OpenVPN Connect 1.2.7

Never run into this problem before the new version was released with iOS 11. Have roughly 65 OpenVPN profiles loaded due to travel reasons. Using a commercial VPN.

Seamless Tunnel On
Connect via Any
Reconnect on wake up On
Protocol Adaptive
Compression Full
Connection Timeout None
Network State Detection Active
IPv6 Disabled
Min TLS 1.2
Allow MD5 On
Layer 2 On

Change History (19)

comment:1 Changed 2 years ago by plaisthos

Not sure about ios but android sometimes the VPN app is accounted for the data traffic that other applciations are using. Maybe it is the same problem here?

Last edited 2 years ago by plaisthos (previous) (diff)

comment:2 Changed 2 years ago by hunterx1

On iOS 11.2.5 the traffic appears to be listed as OpenVPN AND the app that used it. I tested by resetting statistics and running tests with some apps. I used Apple News, and Appstore. Scrolling for a few seconds used up roughly 5MB of LTE, and it showed up under the associated apps as ~5MB each, but OpenVPN listed roughly double which means it listed the the traffic from both tests as OpenVPN.

I see similar results on Win 10 statistics which show all my traffic using OpenVPN, while close to unrealistically low #'s on everything else. My Asus Router with Merlin has a hard time keeping track of my usage stats if I'm using a VPN as well. I don't think this is a bug.There could be some overhead, but the majority of it is your actual traffic. i could be wrong though. My stats for LTE are really low however (taken from my provider app, not apple stats).

comment:3 Changed 2 years ago by Antonio

#1020 has been closed as duplicate, but it contains some screenshots.

comment:4 Changed 2 years ago by Antonio

@hunerx1 I have not fully understood the problem: are you claiming that the App is showing 2.1GB in the stats, but it's actually not really using that much from your data plan?

Or are you claiming that the App is really generating that amount of traffic, even though your Apps are generating very low traffic?

comment:5 in reply to:  4 Changed 2 years ago by hunterx1

Replying to ordex:

@hunerx1 I have not fully understood the problem: are you claiming that the App is showing 2.1GB in the stats, but it's actually not really using that much from your data plan?

Or are you claiming that the App is really generating that amount of traffic, even though your Apps are generating very low traffic?

no, I'm claiming this is not a bug because the data reported as used by OpenVPN is actually caused by other apps while the VPN is on. The data used is listed once for the app, and then again for OpenVPN. This is an issue with iOS recording the data usage twice under 2 apps. I was hoping the original reporter would check to verify my results. I do not have this issue.

comment:6 Changed 2 years ago by Antonio

ok, thanks for clarifying.

comment:7 Changed 2 years ago by Antonio

Summary: OpenVPN Connect iOS used 2.1GB cellular data this periodiOS: used 2.1GB cellular data this period

comment:8 Changed 2 years ago by Antonio

shammalammadingdong: any additional information on this? as of now we can't see if/where there is a bug.

comment:9 Changed 2 years ago by mggw

I think openvpn is bypassing the cellular data policy in iOS.

e.g., I have Appstore turned off in Settings -> Cellular. When on regular LTE (no VPN), it will not connect to the Appstore, let alone download an app. When connected to the VPN, Appstore functions on LTE without issue. Traffic is not counted as App Store traffic, but seems to increase the traffic under openvpn (which is obviously turned on).

comment:10 Changed 2 years ago by Antonio

oh I see, this sounds more like iOS is not blocking AppStore? from operating because it "sense" the connection to be over VPN (rather than LTE). Maybe this should be reported to Apple directly.

comment:11 Changed 2 years ago by mggw

Apple may be responsible, but I think it's unlikely. I was using the Appstore as an example, but this also occurs with my podcasting app (Overcast, for example), and likely other apps. This used to be handled in a way that the cellular data use settings were adhered to, and it didn't matter if openvpn was connected or not. I have only started noticing it recently as my data use keeps on going up. I suspect it is a consequence of the 1.1.1 to 1.2.5 transition, but can't say for sure. On 1.1.1, this was not an issue.

comment:12 Changed 2 years ago by Antonio

Thanks for the additional info!

Well, the app by itself has no way to "advertise" how it is connected (wifi vs lte), also because it has no control over it.

It's iOS that decides where the uplink is (and informs the app in case of changes so that the app can reconnect).
For this reason I would still expect iOS to "block" an app when the uplink is on LTE.

Might be a change due to the new API that the App is now using. I will open an inquiry to Apple to see what they think about it.

Thanks

comment:13 Changed 2 years ago by mggw

Thanks for reaching out to Apple. You may want to report two different bugs, depending on how they respond:

1) When OpenVPN is connected to an active VPN connection on LTE, apps do not adhere to the Cellular data settings. i.e. Apps which are turned 'off' for cellular data, still are able to use cellular data.

2) When OpenVPN is connected to an active VPN connection on LTE, traffic from other apps (all apps?) is counted as OpenVPN traffic.

comment:14 Changed 2 years ago by hunterx1

3) in addition to #2, the usage counts are counted twice. Once for the main app, then again as OpenVPN. Apple needs to pick either the main app or OpenVPN, not both. Windows 10 counts all traffic against the VPN, so statistics are not useful, but they are at least accurate. It should only list for the main app to allow the intended use case to find out which apps use more data. There must be a technical reason, because the same flaw exists everywhere, but Apple duplicates while others don’t. Don’t expect a fix any time soon. Maybe this time next year in iOS 12.x. WWDC is already in June to reveal iOS 12. I would prefer is as is rather than all OpenVPN.

comment:15 Changed 2 years ago by hunterx1

While on LTE, I noticed that a game I was playing which was set to not allow LTE honored the block when OpenVPN was online. I did not test with every app, but it seems that at least some apps work as intended.

comment:16 Changed 2 years ago by mggw

Yes. Seems to be fixed. FYI, I can reproduce in 1.2.8 (0) Beta, but in 1.2.9.

Thanks to whoever fixed. I believe my problem is resolved, but am not sure about OP.

comment:17 Changed 2 years ago by mggw

That should read NOT in 1.2.9. Couldn't figure out how to edit.

comment:18 Changed 2 years ago by Antonio

from 1.2.8 to 1.2.9 there is no code change that is touching anything related to this, thus I think it must be something else in your setup/system.

comment:19 Changed 2 years ago by mggw

That might be the case, although I did downgrade to 1.2.8 (0) + (1) today in test flight, and it only happened in 1.2.8 (0). 1.2.8 (1) and 1.2.9 were fine.

Note: See TracTickets for help on using tickets.