wiki:Topics-2011-06-30

Patches awaiting an ACK

MinGW buildsystem

The "domake-win" / MinGW buildsystem is somewhat outdated. For example, build scripts need to be modified to work with latest software dependencies, such as OpenSSL 1.0.0 and lzo 2.05. There are also some inconsistencies in how it behaves, such as looking for OpenSSL DLL's sometimes from $OPENSSL_DIR, sometimes for $PREBUILT/openssl. We also have another fully functional Windows buildsystem used to make official OpenVPN releases. A few questions:

First, should we try to actively maintain the MinGW buildsystem, provided nobody is filing bug reports or making complaints? Or should we let users who need it provide patches as necessary?

OpenSSL 0.9.6 support

OpenVPN still supports OpenSSL 0.9.6. Last 0.9.6 release was made in 2004. Is there any reason not to remove the unused 0.9.6 codepaths a.s.a.p.?

Last modified 7 years ago Last modified on 06/30/11 08:09:18