Opened 3 years ago

Closed 11 days ago

#919 closed Bug / Defect (duplicate)

Error "OpenVPNROUTE6: cannot parse gateway spec 'net_gateway'"

Reported by: mike_SF Owned by:
Priority: minor Milestone: release 2.6
Component: IPv6 Version: OpenVPN 2.4.0 (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords: --route IPv6 net_gateway
Cc:

Description

On a client with the following entries in the configuration file

route 8.8.8.8 255.255.255.255 net_gateway
route-ipv6 2001:4860:4860::8888/128 net_gateway

The first one (IPv4) works like a charm, but the second one (IPv6) causesthe following error in the log:

OpenVPNROUTE6: cannot parse gateway spec 'net_gateway'

Pseudorandomly replacing net_gateway with net_gateway_ipv6 yields the following error:

OpenVPNROUTE6: cannot parse gateway spec 'net_gateway_ipv6'

In both cases the documented functionality, that a route to that particular IPv6 address is established through the gateway and outside of the VPN, is not established.

Version information:

OpenVPN 2.4.3 x86_64-w64-mingw32 [SSL (OpenSSL)] [LZO] [LZ4] [PKCS11] [AEAD] built on Jun 20 2017
Windows version 6.2 (Windows 8 or greater) 64bit
library versions: OpenSSL 1.0.2l  25 May 2017, LZO 2.10

Change History (2)

comment:1 Changed 3 years ago by tincantech

CC

comment:2 Changed 11 days ago by Gert Döring

Milestone: release 2.4.4release 2.6
Resolution: duplicate
Status: newclosed

This is a duplicate of #1084 (or vice versa) and #1161.

Both have been acknowledged as "yes, there are use cases where this is wanted", but as this is not "just broken" but "not implemented yet" it will not happen in the 2.4.x or 2.5.x train - 2.6 it is.

I am closing this ticket, as we have the other two to track things.

Note: See TracTickets for help on using tickets.