Opened 3 years ago

Last modified 3 years ago

#901 new Bug / Defect

Windows 10 starts a NON-admin cmd when using "Explorer > Start OpenVPN on this config file .."

Reported by: tincantech Owned by:
Priority: minor Milestone:
Component: Generic / unclassified Version:
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

Windows 10 starts a NON-admin cmd window when using "Explorer > Start OpenVPN on this config file .." and the tunnel fails. (Setup with my default-client.ovpn which successfully connects otherwise)

Tested on W10 with Openvpn v242 (will check other windows and openvpn versions in due course)

Change History (1)

comment:1 Changed 3 years ago by tincantech

As a work around I found this:
https://stackoverflow.com/questions/19098101/how-to-open-an-elevated-cmd-using-command-line-for-windows

Recommends this:
1) powershell -Command "Start-Process cmd -Verb RunAs"

If logged in as a computer administrator that works as it stands.

However, if logged in as a standard windows user this is required:
2) powershell -Command "Start-Process cmd -Verb RunAs administrator"

This opens UAC and asks for local Administrator Password and runs an elevated privileges cmd prompt (although, it is not without it's own particular brand of Windows eccentricity, try it yourself for example). Running openvpn from command line in this elevated window works correctly (according to my tests on W10 .. just remember M$ like to screw with things .. )

Integrating option 2. above appears to be a viable solution.
(I have not tried to make the registry changes as yet)

Last edited 3 years ago by tincantech (previous) (diff)
Note: See TracTickets for help on using tickets.