Opened 3 years ago

Closed 4 months ago

#90 closed Bug / Defect (duplicate)

server side route statements are affected by 'topology subnet'

Reported by: janjust Owned by:
Priority: minor Milestone:
Component: Configuration Version: 2.1.4
Severity: Not set (if unsure, select this one) Keywords: topology subnet
Cc:

Description

The sample config

tls-server
proto udp
port 1194
dev tun
server 10.8.0.0 255.255.255.0
ca ca.crt
cert server.crt
key server.key
dh dh1024.pem
route 192.168.4.0 255.255.255.0

works without any issues. If I add

topology subnet

I get

OpenVPN ROUTE: OpenVPN needs a gateway parameter for a
--route option and no default was specified by either
--route-gateway or --ifconfig options
OpenVPN ROUTE: failed to parse/resolve route for
host/network: 192.168.4.0

The same happens if you switch from 'dev tun' to 'dev tap'.
This is (at the very least) confusing to server admins.

A work around is to use

route 192.168.4.0 255.255.255.0 10.8.0.1

in this case but it is a pity that the VPN server IP needs to be explicitly mentioned. Perhaps a special keyword would help, e.g.

route 192.168.4.0 255.255.255.0 vpn_server_ip


Similar things are true for 'iroute' statements

Change History (3)

comment:1 Changed 9 months ago by samuli

Can this be reproduced on recent openvpn versions also?

comment:2 Changed 5 months ago by samuli

  • Keywords topology subnet added

comment:3 Changed 4 months ago by cron2

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #55, closing this one.

Note: See TracTickets for help on using tickets.