Opened 4 years ago

Closed 12 months ago

#876 closed Bug / Defect (wontfix)

manpage using deprecated option "ns-cert-type server"

Reported by: hildeb Owned by: Steffan Karger
Priority: minor Milestone: release 2.3.15
Component: Generic / unclassified Version: OpenVPN 2.3.13 (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

The man page for openvpn says:

persist-key
persist-tun
pkcs12 client.p12
ns-cert-type server
verb 3

But as of 2.4.0, "ns-cert-type server" is deprecated and should instead be:

"remote-cert-tls server"

Change History (2)

comment:1 Changed 4 years ago by Steffan Karger

Milestone: release 2.3.15
Owner: set to Steffan Karger
Status: newaccepted
Version: 2.4.02.3.13

This is already fixed in the 2.4 (and master) man pages, but could use a backport to 2.3.

comment:2 Changed 12 months ago by Steffan Karger

Resolution: wontfix
Status: acceptedclosed

We waited long enough with fixing this that I'm can now say "2.3 is too old, we're not fixing this anymore"...

Note: See TracTickets for help on using tickets.