Opened 4 years ago

Closed 2 years ago

#736 closed Bug / Defect (fixed)

iOS: Opening profiles from iCloud Drive doesn't work (iOS 9 + 10)

Reported by: CallumA Owned by: Antonio
Priority: major Milestone:
Component: OpenVPN Connect Version: OpenVPN Connect for iOS v1.2.6
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords: iOS9, iOS10, Connect, iCloud Drive
Cc: Samuli Seppänen

Description

If an OpenVPN profile is stored in iCloud Drive and the file is opened in OpenVPN Connect (share button -> Copy to OpenVPN Connect) it does not show up in the Connect app. Other apps do work so it does appear to be an OpenVPN Connect thing, rather than an iCloud Drive bug.

This happened to me on iOS 9, a day before I updated to iOS 10 where the bug still exists.

Change History (7)

comment:1 Changed 4 years ago by Gert Döring

Cc: Samuli Seppänen added
Owner: set to jamesyonan
Status: newassigned

comment:2 Changed 4 years ago by Gert Döring

Version: 1.0.7

comment:3 Changed 2 years ago by Antonio

Owner: changed from jamesyonan to Antonio

comment:4 Changed 2 years ago by Antonio

Status: assignedaccepted

This issue has been recently reported again and we have an internal ticket for this.
Hopefully it will be fixed soon.

comment:5 Changed 2 years ago by Antonio

Summary: Opening profiles from iCloud Drive doesn't work (iOS 9 + 10)iOS: Opening profiles from iCloud Drive doesn't work (iOS 9 + 10)
Version: 1.0.7OpenVPN Connect for iOS v1.2.6

comment:6 Changed 2 years ago by Antonio

Hi, this bug has been addressed and its fix will be shipped within v1.2.8.

Unfortunately, I have to say that it works only with one file at once, due to an iOS bug :-( Somebody else already opened a bug report to apple for this (https://openradar.appspot.com/36505593)

Last edited 2 years ago by Antonio (previous) (diff)

comment:7 Changed 2 years ago by Antonio

Resolution: fixed
Status: acceptedclosed

1.2.8 has been approved and is being released to the AppStore?? as we speak. I am finally closing this ticket. Please feel free to re-open it if the issue is not yet solved.

Note: See TracTickets for help on using tickets.