Opened 4 years ago

Closed 3 years ago

#731 closed Bug / Defect (worksforme)

iOS 10 bug OpenVPN connect 1.0.7

Reported by: JYFygyjygkghkkhhkThe Owned by: Antonio
Priority: critical Milestone:
Component: OpenVPN Connect Version: 1.0.7
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

On iOS 10 GM there's a bug that when I'm connected to Wi-Fi and a VPN it will disconnect me from Wi-Fi while on browsing the Internet but it will still say I'm connected to the VPN. It's not a problem with my router I have a very strong signal before disconnects and it only happens on open VPN. I attached the logs from openVPN

OpenVPN connect 1.0.7

Attachments (3)

bug.txt (63.9 KB) - added by JYFygyjygkghkkhhkThe 4 years ago.
Crash log OpenVPN.txt (49.0 KB) - added by JYFygyjygkghkkhhkThe 4 years ago.
Here is a new crash log
Logs.txt (63.9 KB) - added by JYFygyjygkghkkhhkThe 4 years ago.
Here are my logs

Download all attachments as: .zip

Change History (20)

Changed 4 years ago by JYFygyjygkghkkhhkThe

Attachment: bug.txt added

comment:1 Changed 4 years ago by ValdikSS

Cannot reproduce, everything works as expected for me. Does it take time to disconnect you?

comment:2 Changed 4 years ago by JYFygyjygkghkkhhkThe

It happens when I connect to the vpn while I'm connected to wifi. It takes 10 or more minutes to start to disconnect from the wifi. Even with a extremely strong wifi signal.

comment:3 Changed 4 years ago by JYFygyjygkghkkhhkThe

I captured a sysdiagnose and a vpn log while the issue was occurring, I will attach it if it will help. I'm able to replicate it easily and it makes it extremely hard to use the vpn.

comment:4 Changed 4 years ago by JYFygyjygkghkkhhkThe

Sorry about the extra comments, the kept disconnecting me and I thought they were not saving.

Last edited 4 years ago by JYFygyjygkghkkhhkThe (previous) (diff)

comment:5 Changed 4 years ago by JYFygyjygkghkkhhkThe

I captured a vpn log and sysdiagnose while the issue was happing and I will attach them is that can help find the issue. I'm able to replicate the issue very easily and it makes it extremely difficult to use the VPN.

comment:6 Changed 4 years ago by Gert Döring

yes, logs please

comment:7 Changed 4 years ago by JYFygyjygkghkkhhkThe

You have to tap on help and then tap on more help, to cause a crash.

Changed 4 years ago by JYFygyjygkghkkhhkThe

Attachment: Crash log OpenVPN.txt added

Here is a new crash log

comment:8 in reply to:  7 Changed 4 years ago by Gert Döring

Replying to JYFygyjygkghkkhhkThe:

You have to tap on help and then tap on more help, to cause a crash.

Wrong ticket. *This* ticket is waiting for information about your wifi issues.

comment:9 Changed 4 years ago by JYFygyjygkghkkhhkThe

Here is a link to my logs. http://filenurse.com/download/29a416e5d8db6ffe8dda443cb52b2b05.html
Download will expire in 5 days

comment:10 Changed 4 years ago by Gert Döring

Version: 1.0.7

comment:11 Changed 4 years ago by JYFygyjygkghkkhhkThe

I'm still having this issue and it takes a little while to happen but when it does happen it disconnects me from the internet and my Wi-Fi goes away and all it shows is that I'm connected to a 3G network but when I go into settings it says I'm connected to Wi-Fi here's a picture of it and I'm also uploading my logs

Changed 4 years ago by JYFygyjygkghkkhhkThe

Attachment: Logs.txt added

Here are my logs

comment:12 Changed 4 years ago by JYFygyjygkghkkhhkThe

Incorrect links the correct links are below

Last edited 4 years ago by JYFygyjygkghkkhhkThe (previous) (diff)

comment:13 Changed 4 years ago by JYFygyjygkghkkhhkThe

Ignore the previous links here are the new links to my screenshots
https://www.icloud.com/sharedalbum/#B0O5qXGF1K4kyn

comment:14 Changed 4 years ago by JYFygyjygkghkkhhkThe

And here are the settings that are inside of the VPN profile that I use.

client
dev tun
proto udp
remote 94.100.23.162 443
resolv-retry infinite
nobind
persist-key
persist-tun
remote-cert-tls server
cipher AES-256-CBC
comp-lzo no
verb 3
explicit-exit-notify 5
key-direction 1

comment:15 Changed 4 years ago by JYFygyjygkghkkhhkThe

The issue seams to happen less often when "Network state detection" is set to disabled.

comment:16 Changed 3 years ago by Antonio

Owner: set to Antonio
Status: newassigned

Version 1.2.6 is on the AppStore?. Could you please test that and re-open this ticket is the issue is still there?

Thanks!

comment:17 Changed 3 years ago by Antonio

Resolution: worksforme
Status: assignedclosed
Note: See TracTickets for help on using tickets.