Opened 4 years ago

Closed 4 years ago

#691 closed Bug / Defect (duplicate)

Common name variable overwritten

Reported by: Claudi Owned by:
Priority: major Milestone:
Component: Generic / unclassified Version: OpenVPN 2.3.11 (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

I had a problem with my disconnect script and discovered this bug. I am using the $common_name variable in the disconnect script to receive the "username" while having "username-as-common-name" activated. My expected behaviour would be that the $common_name variable always includes the username submitted by the authentication script. But this is not the case. Somewhen this variable is overwritten and the common name from the certificate is written to it. Sadly I can't tell you exactly when this overwriting happens but my assumption is during a TLS renegotiation or ping timeout. It would be nice if you could fix this as I assume further problems if duplicate-cn is not activated. Then multiple people could have the same common name and would then be disconnected because of that.

Change History (3)

comment:1 Changed 4 years ago by Gert Döring

I think there already is a trac ticket for this... need to go search for it tomorrow.

comment:2 Changed 4 years ago by CLaudi

Replying to cron2:

I think there already is a trac ticket for this... need to go search for it tomorrow.

You are right. I am sorry that I didn't find it before opening this ticket. Here is the id: #160

Would it be possible to push the old ticket again as it was opened 5 years and people like me still have problems?

comment:3 Changed 4 years ago by Gert Döring

Resolution: duplicate
Status: newclosed

thanks for digging this up. We'd love to fix all outstanding bugs... it's just a matter of having enough time for "new stuff people want", "bugs that affect a high percentage of users" (like, "crash if..." bugs), and "yes, this is not correct behaviour, but most people will never notice" things...

So apologies for not delivering proper service.

I'm closing this one, as you already pushed up the other one :-)

Note: See TracTickets for help on using tickets.