Opened 22 months ago

Closed 3 days ago

#674 closed Bug / Defect (fixed)

compression issue causing connection issues with iOS OpenVPN Connect client 1.0.5 build 177 and OpenVPN Access Server 2.0.25

Reported by: leerspace Owned by: ordex
Priority: major Milestone:
Component: OpenVPN Connect Version: OpenVPN 2.0.x (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

I recently did a fresh install of OpenVPN Access Server 2.0.25 (coming from 2.0.20). After downloading the new configs to my Mac and iOS device, I found that I could no longer connect from my iOS device (5s, iOS 9.3, OpenVPN Connect client version 1.0.5 build 177).

Looking in /var/log/openvpn.log I noticed a bunch of errors like the ones below spamming the log file.

2016-04-09 18:56:35-0500 [-] OVPN 3 OUT: 'Sat Apr 9 23:56:35 2016 openvpnclient_AUTOLOGIN/172.16.0.1:54871 Bad compression stub decompression header byte: 251'

The workaround I found that seems to effectively sidestep the issue is to disable "Support compression on client VPN connections" in the Advanced VPN settings on the OpenVPN Access Server. Note that this issue never affected my Mac that I connect with using the same client profile (and Tunnelblick as the client).

I'm happy enough with my workaround, but I thought this might be worth reporting.

Change History (3)

comment:1 Changed 21 months ago by cron2

  • Owner set to jamesyonan
  • Status changed from new to assigned

@jamesyonan: seems it's high time to release iOS Connect with "compression v2"?

comment:2 Changed 3 days ago by ordex

  • Owner changed from jamesyonan to ordex

comment:3 Changed 3 days ago by ordex

  • Resolution set to fixed
  • Status changed from assigned to closed

This bug should have been fixed by a later release.

Please feel free to re-open this ticket is the issue persists.

Note: See TracTickets for help on using tickets.