Opened 3 years ago

Closed 15 months ago

#645 closed Bug / Defect (worksforme)

Connect on iOS 9.2: cannot switch from cellular to wifi

Reported by: kvic Owned by: Antonio
Priority: major Milestone:
Component: OpenVPN Connect Version:
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords: connect, iOS 9.2, seamless tunnel, cellular, wifi, switch
Cc:

Description

iPhone being connected to VPN over cellular. Then a WiFI hotspot is detected. iPhone successfully associates itself with the hotspot (i.e. wifi signal bar shows up on the status bar). A bit later captive portal pops up but the hotspot's portal page can never be loaded. Sometimes later iPhone disassociates itself from the hotspot.

Throughout the phases of wifi association and captive portal pop-up, I could see VPN icon on the status bar and never see it disappear for a moment.

OpenVPN Settings in iOS 9.2: Seamless tunnel On, Network state detection Active, Layer 2 reachability On.

Tried different combinations of Network State detection, and Layer 2 reachability but does not resolve the issue. The only option I have not tried is disabling seamless tunnel.

This scenario used to work before iOS 9.2. The behaviour IIRC was that by the time the captive portal pops up, the VPN connection will be dropped. Then users finished login on the captive portal. After that VPN connection was re-established over wifi.

Change History (3)

comment:1 Changed 3 years ago by Gert Döring

Owner: set to jamesyonan
Status: newassigned

comment:2 Changed 15 months ago by Antonio

Owner: changed from jamesyonan to Antonio

v1.2.6 has just been launched on AppStore?. Could you please test that version and re-open this bug if the problem is still there?

Thanks!

comment:3 Changed 15 months ago by Antonio

Resolution: worksforme
Status: assignedclosed
Note: See TracTickets for help on using tickets.