Opened 4 years ago

Last modified 3 years ago

#632 reopened Bug / Defect

I60x installers should warn (or refuse cooperation) on XP

Reported by: Gert Döring Owned by: Samuli Seppänen
Priority: major Milestone: release 2.3.14
Component: Generic / unclassified Version: OpenVPN 2.3.8 (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

$Colleague just installed 2.3.8 I601 on Windows XP, and it pretended a successful installation - but later on the TAP driver did not work ("could not access Tap adapter" from within OpenVPN).

We should print a warning, or just refuse installation and point to the I00x installers

Change History (15)

comment:1 Changed 4 years ago by Samuli Seppänen

I think we should stop the installation and print a warning if the user has not unchecked the "Install/upgrade the TAP virtual device driver" checkbox. This will allow the I60x installers to work on Windows XP, as long as the user does not try install the tap-windows6 driver. Doing it like this is probably not any more work than bailing out immediately. The end result for most people is exactly the same.

comment:2 Changed 4 years ago by Gert Döring

in theory this sounds good - but in practice, when we merge valdikss' patch, the vista+ binaries will not run on XP anyway (due to missing DLL). So I think just telling the users "this is the wrong bundle for you" might be good enough...

Maybe rename the bundles as well, into openvpn-xp-I00x and openvpn-vista+-I60x?

comment:3 Changed 4 years ago by Samuli Seppänen

Ah yes, that one. I'll wait until the dust settles and see what I can do.

comment:4 Changed 4 years ago by Samuli Seppänen

An attempt to fix this was made in commit 65e328 to openvpn-build. However, that fix caused odd issues on Windows XP, and it had to be reverted. Another fix is coming up.

comment:5 Changed 4 years ago by Samuli Seppänen

Milestone: release 2.3.9release 2.3.11

comment:6 Changed 4 years ago by Samuli Seppänen

Milestone: release 2.3.11release 2.3.12

comment:7 Changed 3 years ago by Gert Döring

Milestone: release 2.3.12release 2.3.14

not giving up yet

comment:9 Changed 3 years ago by Samuli Seppänen

@chipitsine: I agree: this bug has been fixed in 2.4.x installers, and backporting the fix to 2.3.x installers is not worth the effort imho.

@cron2: any objections to closing this ticket as fixed?

comment:10 Changed 3 years ago by Gert Döring

Well, that depends - what happens if you install an 2.3-I60x installer on XP today?

If it still pretends "everything is good" then the bug has not been fixed - and since we're going to provide 2.3.x installers for quite a while to come, I see this still as something that should be fixed.

If we stop providing I60x installers, that would also work for XP users :-) - but I think folks on W8+ that do not trust 2.4 yet won't like that.

comment:11 Changed 3 years ago by chipitsine

@mattock, can you please have a look at https://github.com/OpenVPN/tap-windows6/pull/24 ?

I do not own any EV code signing cert, it is tricky to build a package for me.

comment:12 Changed 3 years ago by Samuli Seppänen

@chipitsine: I'll review the PR on GitHub.

Last edited 3 years ago by Samuli Seppänen (previous) (diff)

comment:13 Changed 3 years ago by chipitsine

after https://github.com/OpenVPN/tap-windows6/pull/24 is merged, probably we can close this issue

comment:14 Changed 3 years ago by Samuli Seppänen

Resolution: fixed
Status: newclosed

@chipitsine: I don't think we've yet tested how OpenVPN 2.3.x-I60x installers behave on Windows XP when they launch a tap-windows6 installer with the fix.

comment:15 Changed 3 years ago by Samuli Seppänen

Resolution: fixed
Status: closedreopened

Closed by accident, reopening.

Note: See TracTickets for help on using tickets.