Opened 5 years ago

Closed 13 days ago

#629 closed Bug / Defect (fixed)

Assert at swiching remotes

Reported by: stipa Owned by: plaisthos
Priority: major Milestone:
Component: Networking Version: OpenVPN git master branch (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

Prerequisites

  • config has two remotes:
 remote google.com 1194
 remote vpnhost.com 1194
  • management interface enabled (could be probably reproduced without it)

Steps to reproduce

  • run client
  • say "hold release"
  • say "remote ACCEPT" for a google.com remote
  • wait for connection establishment to fail in 60 secs
  • say "remote ACCEPT" for a google.com remote
  • boom!
Fri Nov 13 14:03:45 2015 us=553767 MANAGEMENT: CMD 'hold release'
Fri Nov 13 14:04:04 2015 us=50234 MANAGEMENT: CMD 'remote SKIP'
Fri Nov 13 14:04:05 2015 us=51525 MANAGEMENT: Client disconnected
Fri Nov 13 14:04:05 2015 us=51562 Assertion failed at init.c:347
Fri Nov 13 14:04:05 2015 us=51570 Exiting due to fatal error

Change History (6)

comment:1 Changed 5 years ago by stipa

Correction: last two steps are:

  • say "remote SKIP" for a google.com remote
  • boom!

comment:2 Changed 5 years ago by stipa

Seems that we're missing this call:

clear_remote_addrlist (&c->c1.link_socket_addr, !c->options.resolve_in_advance);

Which can be added, for example, instead of those asserts.

comment:3 Changed 5 years ago by Gert Döring

Owner: set to plaisthos
Status: newassigned

Arne, I the remote_addrlist stuff smells like "your code" - could you look into this?

comment:4 Changed 5 years ago by plaisthos

Can you post your whole config? I have trouble reproducing this.

Last edited 5 years ago by plaisthos (previous) (diff)

comment:5 Changed 5 years ago by plaisthos

@stipa I am not sure. I think if these assert fail there has been some cleanup missing.

comment:6 Changed 13 days ago by Gert Döring

Resolution: fixed
Status: assignedclosed

commit 3ad86c2534a92af137809b6d446d570193e6d01f (master)
commit 6554025a422d3d7e5465bcbfad34fa3e196b53b0 (release/2.5)
commit 7fdcd286a15fb4f64e979c4fdbf52223d4bdede0 (release/2.4)
Author: Vladislav Grishenko
Date: Wed Sep 16 19:17:55 2020 +0500

Fix fatal error at switching remotes (#629)

Thanks!

Note: See TracTickets for help on using tickets.