Opened 4 years ago

Closed 3 months ago

#60 closed Bug / Defect (duplicate)

--auth-user-pass <file> does not work after TLS soft reset disconnect

Reported by: schmidt Owned by:
Priority: minor Milestone:
Component: Generic / unclassified Version: 2.1.2 / 2.1.3
Severity: Not set (if unsure, select this one) Keywords:
Cc:

Description

config file (client) has "auth-user-pass" and I am overriding this with:

openvpn --config server.conf --auth-user-pass passwd_file

if the server has "reneg-sec 86400" it tries to renegotiate the connection after one day and it fails with this error:
"ERROR: could not read Auth username from stdin"

it just ignores my command line setting "-auth-user-pass passwd_file".

Change History (3)

comment:1 Changed 10 months ago by samuli

I suspect this behavior is what you'd expect with current option parser. Is this something we should fix, and if so, is it a small or a major chance?

comment:2 Changed 3 months ago by cron2

It violates the principle of least astonishment ("it's all static data, why is it all of a sudden trying to read this from stdin?"), so it should work.

There's this other --auth-user-pass inline? patch floating around, so we should review that one, and see if it fixes this use case as well. I suspect it does.

comment:3 Changed 3 months ago by cron2

  • Resolution set to duplicate
  • Status changed from new to closed

... coming back to this. The patch from Davide Brini actually makes this more explicit as it adds a message

+ msg (M_USAGE, "Cannot use --auth-nocache with credentials from file");

... but that is not actually *solving* the use case (which people have made a good point for).

I'm closing *this* bug, as it's a duplicate of #225, and there is more info over there.

Note: See TracTickets for help on using tickets.