Opened 5 years ago

Closed 5 years ago

#588 closed Bug / Defect (worksforme)

config.status: error: could not create version.sh

Reported by: dogbert2 Owned by:
Priority: major Milestone:
Component: Building / Compiling Version: OpenVPN 2.3.5 (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords: division by zero
Cc:

Description

While building OpenVPN 2.3.7 on Fedora 22 Server, I received the following error during ./configure:

checking that generated files are newer than configure... done
configure: creating ./config.status
config.status: creating version.sh
gawk: ./conffDjlFi/subs.awk:96: fatal: division by zero attempted
config.status: error: could not create version.sh

here is the configure line I used:

./configure LZO_CFLAGS="-I/usr/local/include/lzo/" LZO_LIBS="-L/usr/local/lib/" OPENSSL_SSL_CFLAGS="-I/usr/local/ssl/include/" OPENSSL_SSL_LIBS="-L/usr/local/ssl/lib/" OPENSSL_CRYPTO_LIBS="-L/usr/local/ssl/" OPENSSL_CRYPTO_CFLAGS="-I/usr/local/ssl/include/"

OpenSSL build is 1.0.2d (from source tarball) - successful
LZO build is 2.0.9 (from source tarball) - successful

Attachments (2)

openvpn-config.log (231.2 KB) - added by dogbert2 5 years ago.
config.log file for bug-report
config.status (75.1 KB) - added by dogbert2 5 years ago.
Attachment request per email…

Download all attachments as: .zip

Change History (6)

Changed 5 years ago by dogbert2

Attachment: openvpn-config.log added

config.log file for bug-report

comment:1 Changed 5 years ago by Gert Döring

2.3.7 or 2.3.6? your config log talks about 2.3.6 - but besides that, is not showing the actual error...

Can you please attach the "config.status" script generated to the trac?

(As a side note: the issue might be caused by your "...LIBS" and "...INCLUDE" settings having a trailing "/" - it should be just "-I/usr/local/include/lzo" etc.)

Changed 5 years ago by dogbert2

Attachment: config.status added

Attachment request per email...

comment:2 Changed 5 years ago by dogbert2

It is version 2.3.6, and it produces the same error with or without the trailing slashes on the ./configure line.

checking that generated files are newer than configure... done
configure: creating ./config.status
config.status: creating version.sh
gawk: ./confz4fiYP/subs.awk:96: fatal: division by zero attempted
config.status: error: could not create version.sh

comment:3 Changed 5 years ago by dogbert2

I tried this with version 2.3.8 just downloaded, success on configure...appears to be an issue linked to 2.3.6, it would appear. I am doing 'make' on 2.3.8 as I write this.

comment:4 Changed 5 years ago by Gert Döring

Resolution: worksforme
Status: newclosed

Very strange. But if it works on 2.3.8, we don't *really* care to track down obscure autoconf bugs...

(We do test on a number of different linux and BSD versions, and different autoconf versions, so it's not like we just shipped 2.3.6 with a broken configure...)

Note: See TracTickets for help on using tickets.