Opened 4 years ago

Closed 4 years ago

#566 closed Bug / Defect (invalid)

upon reconnect, OpenVPN removes routes it did not create

Reported by: triffid_hunter Owned by:
Priority: major Milestone:
Component: Generic / unclassified Version: OpenVPN 2.3.6 (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

#412 affects me. My openvpn server apparently pushes redirect-gateway def1, so I cannot test without this option.

Originally I was working around this by adding a /24 route for the ip-range of my VPN servers, however I soon discovered that openvpn would remove it upon reconnect.

This is unfortunate, because if openvpn left user-created routes alone, adding a /24 (or relevant-sized subnet) would be a trivial workaround for #412.

I also found that openvpn will remove routes for specific services that I want to bypass the VPN upon reconnect!

OpenVPN should keep a list of all the changes it's made to the routing table so it can roll them back without affecting other similar rules.

This may also solve #544, which is related but not a duplicate.

(gentoo linux, openvpn 2.3.6)

Change History (2)

comment:1 Changed 4 years ago by Gert Döring

Normally, OpenVPN is quite good at only removing stuff that it created itself (and it's part of our regression test suite to compare routing table entries before/after an openvpn run to ensure no differences).

Can you show a log file demonstrating the route removal, please, including "ip route show" output before OpenVPN is started and after it ends?

(I'm not claiming it's not happening, I just wonder what constellation triggers this)

comment:2 Changed 4 years ago by Gert Döring

Resolution: invalid
Status: newclosed

As long as I can't see a log file, I cannot do anything about this - so closing for now.

Reopen if you have a log for me.

Note: See TracTickets for help on using tickets.