Opened 5 years ago

Closed 4 years ago

#525 closed Feature Wish (fixed)

static-challenge not working in OpenVPN GUI

Reported by: pbellchambers Owned by: selvanair
Priority: major Milestone: release 2.4
Component: Windows GUI Version: OpenVPN 2.3.6 (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords: static-challenge windows
Cc:

Description

OpenVPN GUI (v5) as bundled with OpenVPN v2.3.6
Windows 8.1 64bit

The "static-challenge" option doesn't seem to be working. I have an .ovpn config with:

static-challenge "Enter Google Authenticator Code" 1

If I use openvpn on the command line this prompts the user to enter a value when connecting, however if I use OpenVPN GUI the user is unable to enter any value for this challenge, there is no prompt, the connection just fails.

Change History (6)

comment:1 Changed 5 years ago by Samuli Seppänen

Keywords: windows added
Milestone: release 2.5
Owner: set to Heiko Hund
Status: newassigned

comment:2 Changed 4 years ago by selvanair

Support for static challenge is now in the latest GUI sources.

comment:3 Changed 4 years ago by Gert Döring

Milestone: release 2.5release 2.4
Owner: changed from Heiko Hund to snair
Type: Bug / DefectFeature Wish

So this should "just work" in the 2.4_alpha2 installers that we have, right?

In which case we can just close this ticket :-)

(The functionality might eventually hit 2.3 as well, if I understand Selva and Samuli right, regarding GUI branches, but for now, the cool new stuff is in 2.4)

comment:4 Changed 4 years ago by selvanair

Owner: changed from snair to selvanair
Status: assignedaccepted

comment:5 Changed 4 years ago by selvanair

fixed in GUI version 11.0 included with 2.4_alpha2 installers.

comment:6 Changed 4 years ago by selvanair

Resolution: fixed
Status: acceptedclosed
Note: See TracTickets for help on using tickets.